<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11" />
			<link rel="shortcut icon" href="https://newspress.com//////wp-content/uploads/2019/05/sbnp-logo-circle.png" type="image/x-icon" />
		<link rel="apple-touch-icon" sizes="180x180" href="https://newspress.com//////wp-content/uploads/2019/05/sbnp-logo-circle.png">
		<link rel="alternate" type="application/rss+xml" title="Santa Barbara News-Press RSS Feed" href="https://newspress.com/feed/" />
	<link rel="alternate" type="application/atom+xml" title="Santa Barbara News-Press Atom Feed" href="https://newspress.com/feed/atom/" />
	<link rel="pingback" href="https://newspress.com/xmlrpc.php" />
	<!--[if lt IE 9]>
	<script src="https://newspress.com/wp-content/themes/soledad/js/html5.js"></script>
	<![endif]-->
	
	<!-- This site is optimized with the Yoast SEO plugin v16.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>United Way offers millions in rent relief - Santa Barbara News-Press</title>
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://newspress.com/united-way-offers-millions-in-rent-relief/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="United Way offers millions in rent relief - Santa Barbara News-Press" />
	<meta property="og:description" content="The United Way of Santa Barbara County is in the early stages of distributing more than&hellip;" />
	<meta property="og:url" content="https://newspress.com/united-way-offers-millions-in-rent-relief/" />
	<meta property="og:site_name" content="Santa Barbara News-Press" />
	<meta property="article:publisher" content="https://www.facebook.com/santabarbaranewspress/" />
	<meta property="article:published_time" content="2021-03-31T12:57:00+00:00" />
	<meta property="article:modified_time" content="2021-03-31T12:57:44+00:00" />
	<meta property="og:image" content="https://newspress.com/wp-content/uploads/2020/06/santa-barbara-newspress-local-news.jpg" />
	<meta property="og:image:width" content="500" />
	<meta property="og:image:height" content="376" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@sbnpnews" />
	<meta name="twitter:site" content="@sbnpnews" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Madison Hirneisen">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="3 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://newspress.com/#organization","name":"Santa Barbara News-Press","url":"https://newspress.com/","sameAs":["https://www.facebook.com/santabarbaranewspress/","https://www.instagram.com/sbnpnews/","https://twitter.com/sbnpnews"],"logo":{"@type":"ImageObject","@id":"https://newspress.com/#logo","inLanguage":"en-US","url":"https://newspress.com/wp-content/uploads/2019/05/sbnp-logo-sq.jpg","width":778,"height":778,"caption":"Santa Barbara News-Press"},"image":{"@id":"https://newspress.com/#logo"}},{"@type":"WebSite","@id":"https://newspress.com/#website","url":"https://newspress.com/","name":"Santa Barbara News-Press","description":"Southern California&#039;s longest running news publication","publisher":{"@id":"https://newspress.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://newspress.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://newspress.com/united-way-offers-millions-in-rent-relief/#primaryimage","inLanguage":"en-US","url":"https://newspress.com/wp-content/uploads/2020/06/santa-barbara-newspress-local-news.jpg","width":500,"height":376},{"@type":"WebPage","@id":"https://newspress.com/united-way-offers-millions-in-rent-relief/#webpage","url":"https://newspress.com/united-way-offers-millions-in-rent-relief/","name":"United Way offers millions in rent relief - Santa Barbara News-Press","isPartOf":{"@id":"https://newspress.com/#website"},"primaryImageOfPage":{"@id":"https://newspress.com/united-way-offers-millions-in-rent-relief/#primaryimage"},"datePublished":"2021-03-31T12:57:00+00:00","dateModified":"2021-03-31T12:57:44+00:00","breadcrumb":{"@id":"https://newspress.com/united-way-offers-millions-in-rent-relief/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://newspress.com/united-way-offers-millions-in-rent-relief/"]}]},{"@type":"BreadcrumbList","@id":"https://newspress.com/united-way-offers-millions-in-rent-relief/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://newspress.com/","url":"https://newspress.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://newspress.com/united-way-offers-millions-in-rent-relief/","url":"https://newspress.com/united-way-offers-millions-in-rent-relief/","name":"United Way offers millions in rent relief"}}]},{"@type":"Article","@id":"https://newspress.com/united-way-offers-millions-in-rent-relief/#article","isPartOf":{"@id":"https://newspress.com/united-way-offers-millions-in-rent-relief/#webpage"},"author":{"@id":"https://newspress.com/#/schema/person/ebd0d756084a631d6882b2b1b61dd2af"},"headline":"United Way offers millions in rent relief","datePublished":"2021-03-31T12:57:00+00:00","dateModified":"2021-03-31T12:57:44+00:00","mainEntityOfPage":{"@id":"https://newspress.com/united-way-offers-millions-in-rent-relief/#webpage"},"commentCount":0,"publisher":{"@id":"https://newspress.com/#organization"},"image":{"@id":"https://newspress.com/united-way-offers-millions-in-rent-relief/#primaryimage"},"articleSection":"Local","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://newspress.com/united-way-offers-millions-in-rent-relief/#respond"]}]},{"@type":"Person","@id":"https://newspress.com/#/schema/person/ebd0d756084a631d6882b2b1b61dd2af","name":"Madison Hirneisen","image":{"@type":"ImageObject","@id":"https://newspress.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/4259d64353e25d3648ebcf2284f8f6b2?s=96&d=blank&r=g","caption":"Madison Hirneisen"},"description":"News-Press Staff Writer"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//js.stripe.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Santa Barbara News-Press &raquo; Feed" href="https://newspress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Santa Barbara News-Press &raquo; Comments Feed" href="https://newspress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Santa Barbara News-Press &raquo; United Way offers millions in rent relief Comments Feed" href="https://newspress.com/united-way-offers-millions-in-rent-relief/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v7.17.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-138341106-1"  type="text/javascript" data-cfasync="false"></script>
			<script type="text/javascript" data-cfasync="false">
				var mi_version = '7.17.0';
				var mi_track_user = true;
				var mi_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-138341106-1';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( mi_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dZGIzZG' : true,
						                    });
					__gtagTracker( 'config', 'UA-138341106-1', {
						forceSSL:true,link_attribution:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( typeof arguments[5] === 'object' ) {
											Object.assign( hitObject, arguments[5] );
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/newspress.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://newspress.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://newspress.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='wc-block-vendors-style-css'  href='https://newspress.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/vendors-style.css?ver=4.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='wc-block-style-css'  href='https://newspress.com/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/style.css?ver=4.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='topbar-css'  href='https://newspress.com/wp-content/plugins/top-bar/inc/../css/topbar_style.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-layout-css'  href='https://newspress.com/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=5.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://newspress.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=5.1.0' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='https://newspress.com/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=5.1.0' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='issuem-leaky-paywall-css'  href='https://newspress.com/wp-content/plugins/leaky-paywall//css/issuem-leaky-paywall.css?ver=4.16.0' type='text/css' media='all' />
<link rel='stylesheet' id='leaky-paywall-article-countdown-nag-css'  href='https://newspress.com/wp-content/plugins/leaky-paywall-article-countdown-nag/css/article-countdown-nag.css?ver=3.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='penci-fonts-css'  href='//fonts.googleapis.com/css?family=PT+Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CRoboto+Slab%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CRaleway%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='penci_style-css'  href='https://newspress.com/wp-content/themes/soledad/style.css?ver=7.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='date-time-widget-styles-css'  href='https://newspress.com/wp-content/plugins/date-and-time-widget/css/widget.css?ver=5.6.2' type='text/css' media='all' />
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/newspress.com","hash_tracking":"false","ua":"UA-138341106-1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://newspress.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=7.17.0' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://newspress.com/wp-content/plugins/shortcode-for-current-date/dist/script.js?ver=5.6.2' id='shortcode-for-current-date-script-js'></script>
<script type='text/javascript' src='https://newspress.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://newspress.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='topbar_frontjs-js-extra'>
/* <![CDATA[ */
var tpbr_settings = {"fixed":"notfixed","user_who":"notloggedin","guests_or_users":"all","message":"SUBSCRIBE TO SANTA BARBARA NEWS-PRESS","status":"inactive","yn_button":"button","color":"#01579b","button_text":"SUBSCRIBE","button_url":"\/subscribe","button_behavior":"samewindow","is_admin_bar":"no","detect_sticky":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://newspress.com/wp-content/plugins/top-bar/inc/../js/tpbr_front.min.js?ver=5.6.2' id='topbar_frontjs-js'></script>
<script type='text/javascript' src='https://newspress.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70' id='jquery-blockui-js'></script>
<script type='text/javascript' id='wc-add-to-cart-js-extra'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/newspress.com","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='https://newspress.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=5.1.0' id='wc-add-to-cart-js'></script>
<script type='text/javascript' src='https://newspress.com/wp-content/plugins/js_composer/assets/js/vendors/woocommerce-add-to-cart.js?ver=6.6.0' id='vc_woocommerce-add-to-cart-js-js'></script>
<script type='text/javascript' src='https://newspress.com/wp-content/plugins/leaky-paywall/js/js-cookie.js?ver=4.16.0' id='js_cookie_js-js'></script>
<script type='text/javascript' id='leaky_paywall_cookie_js-js-extra'>
/* <![CDATA[ */
var leaky_paywall_cookie_ajax = {"ajaxurl":"\/wp-admin\/admin-ajax.php","post_container":"article .entry-content","page_container":"article .entry-content","lead_in_elements":"2"};
/* ]]> */
</script>
<script type='text/javascript' src='https://newspress.com/wp-content/plugins/leaky-paywall/js/leaky-paywall-cookie.js?ver=4.16.0' id='leaky_paywall_cookie_js-js'></script>
<script type='text/javascript' id='leaky_paywall_script-js-extra'>
/* <![CDATA[ */
var leaky_paywall_script_ajax = {"ajaxurl":"\/wp-admin\/admin-ajax.php","stripe_pk":"pk_live_5xDSyk21etmqfgKlsJuXYpIB0063FMld6m"};
/* ]]> */
</script>
<script type='text/javascript' src='https://newspress.com/wp-content/plugins/leaky-paywall/js/script.js?ver=4.16.0' id='leaky_paywall_script-js'></script>
<script type='text/javascript' id='leaky-paywall-article-countdown-nag-js-extra'>
/* <![CDATA[ */
var lp_acn = {"ajaxurl":"https:\/\/newspress.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://newspress.com/wp-content/plugins/leaky-paywall-article-countdown-nag/js/article-countdown-nag.js?ver=3.7.3' id='leaky-paywall-article-countdown-nag-js'></script>
<script type='text/javascript' src='https://newspress.com/wp-content/plugins/date-and-time-widget/js/widget.js?ver=5.6.2' id='date-time-script-js'></script>
<script type='text/javascript' src='https://js.stripe.com/v3/?ver=5.6.2' id='stripe-js'></script>
<link rel="https://api.w.org/" href="https://newspress.com/wp-json/" /><link rel="alternate" type="application/json" href="https://newspress.com/wp-json/wp/v2/posts/31880" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://newspress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://newspress.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://newspress.com/?p=31880' />
<link rel="alternate" type="application/json+oembed" href="https://newspress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnewspress.com%2Funited-way-offers-millions-in-rent-relief%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://newspress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnewspress.com%2Funited-way-offers-millions-in-rent-relief%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.29.0" />  <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    _Mrec = googletag.defineSlot('/1028104/Homepage_ATF_300x250', [300, 250], 'div-gpt-ad-1573199819719-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
  _Mrec =   googletag.defineSlot('/1028104/Homepage_BTF_300x250', [300, 250], 'div-gpt-ad-1573203443043-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/Frontpage_leaderboard1', [728, 90], 'div-gpt-ad-1576654759047-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/Frontpage_leaderboard2', [728, 90], 'div-gpt-ad-1576655010445-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/frontpage_mobile1', [300, 250], 'div-gpt-ad-1576897014344-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/frontpage_mobile2', [300, 250], 'div-gpt-ad-1576897046488-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script><style type="text/css">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</style><script>
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script>
<script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/newspress.com\/\/\/\/\/\/wp-content\/uploads\/2019\/03\/sbnp-logo-with-bldg500.png"
    },
    "url": "https:\/\/newspress.com\/",
    "name": "Santa Barbara News-Press",
    "description": "Southern California&#039;s longest running news publication"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "Santa Barbara News-Press",
    "alternateName": "Southern California&#039;s longest running news publication",
    "url": "https:\/\/newspress.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "United Way offers millions in rent relief",
    "description": "The United Way of Santa Barbara County is in the early stages of distributing more than&hellip;",
    "datePublished": "2021-03-31",
    "datemodified": "2021-03-31",
    "mainEntityOfPage": "https:\/\/newspress.com\/united-way-offers-millions-in-rent-relief\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/newspress.com\/wp-content\/uploads\/2020\/06\/santa-barbara-newspress-local-news.jpg",
        "width": 500,
        "height": 376
    },
    "publisher": {
        "@type": "Organization",
        "name": "Santa Barbara News-Press",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/newspress.com\/\/\/\/\/\/wp-content\/uploads\/2019\/03\/sbnp-logo-with-bldg500.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-MadisonHirneisen",
        "name": "Madison Hirneisen"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https:\/\/newspress.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https:\/\/newspress.com\/category\/local\/",
                "name": "Local"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https:\/\/newspress.com\/united-way-offers-millions-in-rent-relief\/",
                "name": "United Way offers millions in rent relief"
            }
        }
    ]
}</script>	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-2729663111534818","enable_page_level_ads":true,"tag_partner":"site_kit"});</script><noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/InPost_leaderboard1', [728, 90], 'div-inpost-leader1').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/inpost_mobile1', [300, 250], 'div-gpt-ad-1576899293313-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/InPost_leaderboard2', [728, 90], 'div-inpost-leader2').addService(googletag.pubads());
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/inpost_mobile2', [300, 250], 'div-gpt-ad-1576899369282-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/InPost_leaderboard1', [728, 90], 'div-inpost-leader1').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/inpost_mobile1', [300, 250], 'div-gpt-ad-1576899293313-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/InPost_leaderboard2', [728, 90], 'div-inpost-leader2').addService(googletag.pubads());
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/inpost_mobile2', [300, 250], 'div-gpt-ad-1576899369282-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/InPost_leaderboard1', [728, 90], 'div-inpost-leader1').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/inpost_mobile1', [300, 250], 'div-gpt-ad-1576899293313-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/InPost_leaderboard2', [728, 90], 'div-inpost-leader2').addService(googletag.pubads());
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/inpost_mobile2', [300, 250], 'div-gpt-ad-1576899369282-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
</head>

<body class="post-template-default single single-post postid-31880 single-format-standard theme-soledad woocommerce-no-js wpb-js-composer js-comp-ver-6.6.0 vc_responsive">
	<a id="close-sidebar-nav" class="header-2"><i class="penci-faicon fa fa-close" ></i></a>
	<nav id="sidebar-nav" class="header-2" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">

					<div id="sidebar-nav-logo">
									<a href="https://newspress.com/"><img class="penci-lazy" src="https://newspress.com/wp-content/themes/soledad/images/penci-holder.png" data-src="https://newspress.com//////wp-content/uploads/2019/03/sbnp-logo-word300.png" alt="Santa Barbara News-Press" /></a>
							</div>
		
					<div class="header-social sidebar-nav-social">
				<div class="inner-header-social">
			<a href="https://www.facebook.com/santabarbaranewspress/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook" ></i></a>
				<a href="https://twitter.com/sbnpnews" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter" ></i></a>
				<a href="https://instagram.com/sbnpnews" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram" ></i></a>
										<a href="mailto:webmaster@newspress.com"><i class="penci-faicon fa fa-envelope" ></i></a>
																											</div>			</div>
		
		<ul id="menu-sections" class="menu"><li id="menu-item-8231" class="multi-line menu-item menu-item-type-custom menu-item-object-custom menu-item-8231"><a target="_blank" href="https://issuu.com/sbnpvirtual"><b>Virtual Edition</b></a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-15"><a href="https://newspress.com/category/local/"><b>Local</b></a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><div class="penci-megamenu">				<div class="penci-mega-child-categories">
							<a class="mega-cat-child cat-active all-style"
				   href="https://newspress.com/category/local/"
				   data-id="penci-mega-8"><span>All</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/celebrations/"
				   data-id="penci-mega-3452"><span>Celebrations</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/coronavirus-pandemic-2020/"
				   data-id="penci-mega-2920"><span>Coronavirus Pandemic 2020</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/death-notices/"
				   data-id="penci-mega-3450"><span>Death Notices</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/election/"
				   data-id="penci-mega-3462"><span>Election</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/news-brief/"
				   data-id="penci-mega-3448"><span>News Brief</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/traffic-crime-blotter/"
				   data-id="penci-mega-3451"><span>Traffic &amp; Crime Blotter</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/voices/"
				   data-id="penci-mega-10"><span>Voices</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/voices/opinions-letters/"
				   data-id="penci-mega-11"><span>Opinions-Letters</span></a>
					</div>
		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
								<div class="penci-mega-row penci-mega-8 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lcw-hiking-033121-1-585x390.jpg" href="https://newspress.com/enjoying-sbs-beauty/" title="Enjoying SB’s beauty">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/enjoying-sbs-beauty/" title="Enjoying SB’s beauty">Enjoying SB’s beauty</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T06:00:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lcw-mailes-033121-585x390.jpg" href="https://newspress.com/mailes-appointed-as-new-fire-chief/" title="Mailes appointed as new fire chief">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/mailes-appointed-as-new-fire-chief/" title="Mailes appointed as new fire chief">Mailes appointed as new fire chief</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:59:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lcw-MagicCastle-033121-1-585x390.jpg" href="https://newspress.com/larsens-to-sell-magic-castle-cabaret/" title="Larsens to sell Magic Castle Cabaret">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/larsens-to-sell-magic-castle-cabaret/" title="Larsens to sell Magic Castle Cabaret">Larsens to sell Magic Castle Cabaret</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:58:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/06/santa-barbara-newspress-local-news.jpg" href="https://newspress.com/united-way-offers-millions-in-rent-relief/" title="United Way offers millions in rent relief">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/united-way-offers-millions-in-rent-relief/" title="United Way offers millions in rent relief">United Way offers millions in rent relief</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:57:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3452">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/12/c_Andersson122020-e1608244434405.jpg" href="https://newspress.com/celebrations-12-20-20/" title="Celebrations: 12-20-20">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/celebrations-12-20-20/" title="Celebrations: 12-20-20">Celebrations: 12-20-20</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-12-20T05:00:11-08:00">December 20, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/11/c_Tovar2_112220-e1605900724282.jpg" href="https://newspress.com/celebrations-11-22-20/" title="Celebrations: 11-22-20">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/celebrations-11-22-20/" title="Celebrations: 11-22-20">Celebrations: 11-22-20</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-11-22T05:00:59-08:00">November 22, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/10/c_Mercado1_102520-e1603485600734.jpg" href="https://newspress.com/celebrations-10-25-20-2/" title="Celebrations: 10-25-20">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/celebrations-10-25-20-2/" title="Celebrations: 10-25-20">Celebrations: 10-25-20</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-10-25T05:01:00-07:00">October 25, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/10/c_Spiro102520-e1603485241577.jpg" href="https://newspress.com/celebrations-10-25-20/" title="Celebrations: 10-25-20">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/celebrations-10-25-20/" title="Celebrations: 10-25-20">Celebrations: 10-25-20</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-10-25T05:00:00-07:00">October 25, 2020</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-2920">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/03/coronavirus-cellular-picture-585x390.jpg" href="https://newspress.com/sb-county-reports-30-covid-19-cases-two-deaths/" title="SB County reports 30 COVID-19 cases, two deaths">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sb-county-reports-30-covid-19-cases-two-deaths/" title="SB County reports 30 COVID-19 cases, two deaths">SB County reports 30 COVID-19 cases, two deaths</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:55:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/03/coronavirus-cellular-picture-585x390.jpg" href="https://newspress.com/county-reports-29-covid-19-cases-one-death/" title="County reports 29 COVID-19 cases, one death">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/county-reports-29-covid-19-cases-one-death/" title="County reports 29 COVID-19 cases, one death">County reports 29 COVID-19 cases, one death</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-30T05:57:00-07:00">March 30, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/03/coronavirus-santa-barbara-county-585x390.jpg" href="https://newspress.com/santa-barbara-county-reports-32-covid-19-cases/" title="Santa Barbara County reports 32 COVID-19 cases">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/santa-barbara-county-reports-32-covid-19-cases/" title="Santa Barbara County reports 32 COVID-19 cases">Santa Barbara County reports 32 COVID-19 cases</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:48:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/03/coronavirus-cellular-picture-585x390.jpg" href="https://newspress.com/santa-barbara-county-confirms-26-new-covid-19-cases/" title="Santa Barbara County confirms 26 new COVID-19 cases">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/santa-barbara-county-confirms-26-new-covid-19-cases/" title="Santa Barbara County confirms 26 new COVID-19 cases">Santa Barbara County confirms 26 new COVID-19 cases</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:54:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3450">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/09/santa-barbara-newspress-death-notice-4-585x390.jpg" href="https://newspress.com/death-notice-25/" title="DEATH NOTICE">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/death-notice-25/" title="DEATH NOTICE">DEATH NOTICE</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-27T05:52:00-07:00">March 27, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/09/santa-barbara-newspress-death-notice-4-585x390.jpg" href="https://newspress.com/death-notice-24/" title="DEATH NOTICE">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/death-notice-24/" title="DEATH NOTICE">DEATH NOTICE</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-22T06:03:00-07:00">March 22, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/09/santa-barbara-newspress-death-notice-4-585x390.jpg" href="https://newspress.com/death-notices-28/" title="DEATH NOTICES">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/death-notices-28/" title="DEATH NOTICES">DEATH NOTICES</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-14T05:55:00-07:00">March 14, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/09/santa-barbara-newspress-death-notice-4-585x390.jpg" href="https://newspress.com/death-notice-23/" title="DEATH NOTICE">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/death-notice-23/" title="DEATH NOTICE">DEATH NOTICE</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-11T05:52:00-08:00">March 11, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3462">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/11/lcw-TrumpBiden-100120-1-e1605161812108-585x345.jpg" href="https://newspress.com/locals-discuss-voter-fraud-allegations/" title="Locals discuss voter fraud allegations">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/locals-discuss-voter-fraud-allegations/" title="Locals discuss voter fraud allegations">Locals discuss voter fraud allegations</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-11-12T05:59:37-08:00">November 12, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/11/lcw-Biden-110720-585x390.jpg" href="https://newspress.com/biden-declared-winner/" title="UPDATED: Biden declared winner, calls for unity">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/biden-declared-winner/" title="UPDATED: Biden declared winner, calls for unity">UPDATED: Biden declared winner, calls for unity</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-11-07T09:53:38-08:00">November 7, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/11/lcw-TrumpBiden-100120-585x390.jpg" href="https://newspress.com/local-republicans-democrats-remain-optimistic/" title="Local Republicans, Democrats remain optimistic">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/local-republicans-democrats-remain-optimistic/" title="Local Republicans, Democrats remain optimistic">Local Republicans, Democrats remain optimistic</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-11-05T05:59:00-08:00">November 5, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/11/lcw-ColdSprings-110520-585x390.jpg" href="https://newspress.com/school-measures-board-races-remain-tight/" title="School measures, board races remain tight">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/school-measures-board-races-remain-tight/" title="School measures, board races remain tight">School measures, board races remain tight</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-11-05T05:58:00-08:00">November 5, 2020</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3448">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/07/lcw-Library-070219-141-585x390.jpg" href="https://newspress.com/santa-barbara-library-sponsors-reading-program/" title="Santa Barbara Library sponsors reading program">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/santa-barbara-library-sponsors-reading-program/" title="Santa Barbara Library sponsors reading program">Santa Barbara Library sponsors reading program</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:56:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/06/santa-barbara-newspress-local-news.jpg" href="https://newspress.com/sm-main-library-reopens-for-short-visits/" title="SM main library reopens for short visits">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sm-main-library-reopens-for-short-visits/" title="SM main library reopens for short visits">SM main library reopens for short visits</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:55:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/04/caltrans-logo-585x390.png" href="https://newspress.com/funds-allocated-for-transportation-improvements/" title="Funds allocated for transportation improvements">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/funds-allocated-for-transportation-improvements/" title="Funds allocated for transportation improvements">Funds allocated for transportation improvements</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:54:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/06/santa-barbara-newspress-local-news.jpg" href="https://newspress.com/naturetrack-leads-hike-for-grandparents-and-grandchildren/" title="NatureTrack leads hike for grandparents and grandchildren">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/naturetrack-leads-hike-for-grandparents-and-grandchildren/" title="NatureTrack leads hike for grandparents and grandchildren">NatureTrack leads hike for grandparents and grandchildren</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:53:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3451">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/09/Santa-Barbara-News-Press-Crime-2-585x390.jpg" href="https://newspress.com/traffic-crime-and-fire-blotter-137/" title="Traffic, Crime and Fire Blotter">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/traffic-crime-and-fire-blotter-137/" title="Traffic, Crime and Fire Blotter">Traffic, Crime and Fire Blotter</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:54:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/09/Santa-Barbara-News-Press-Crime-2-585x390.jpg" href="https://newspress.com/traffic-crime-and-fire-blotter-136/" title="Traffic, Crime and Fire Blotter">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/traffic-crime-and-fire-blotter-136/" title="Traffic, Crime and Fire Blotter">Traffic, Crime and Fire Blotter</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-30T05:56:00-07:00">March 30, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lcw-blotter-032921-1-e1617003046848-585x390.jpg" href="https://newspress.com/traffic-crime-and-fire-blotter-135/" title="Traffic, Crime and Fire Blotter">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/traffic-crime-and-fire-blotter-135/" title="Traffic, Crime and Fire Blotter">Traffic, Crime and Fire Blotter</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:57:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lcw-blotter-032821-1-1-585x390.jpg" href="https://newspress.com/traffic-crime-and-fire-blotter-134/" title="Traffic, Crime and Fire Blotter">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/traffic-crime-and-fire-blotter-134/" title="Traffic, Crime and Fire Blotter">Traffic, Crime and Fire Blotter</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:57:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-10">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/ed-MissionCreek-032821-585x390.jpg" href="https://newspress.com/save-mission-creek-bridge/" title="Save Mission Creek Bridge">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/save-mission-creek-bridge/" title="Save Mission Creek Bridge">Save Mission Creek Bridge</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:46:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/07/sbnp-editorial-585x390.jpg" href="https://newspress.com/immigration-reform-must-start-with-secure-borders/" title="Immigration reform must start with secure borders">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/immigration-reform-must-start-with-secure-borders/" title="Immigration reform must start with secure borders">Immigration reform must start with secure borders</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:45:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/ed-buckley-032121-cropped.jpg" href="https://newspress.com/end-of-empire/" title="End of empire">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/end-of-empire/" title="End of empire">End of empire</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:44:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/07/sbnp-editorial-585x390.jpg" href="https://newspress.com/when-preservation-is-greed-by-another-name/" title="When preservation is greed by another name">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/when-preservation-is-greed-by-another-name/" title="When preservation is greed by another name">When preservation is greed by another name</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:43:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-11">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/ed-MissionCreek-032821-585x390.jpg" href="https://newspress.com/save-mission-creek-bridge/" title="Save Mission Creek Bridge">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/save-mission-creek-bridge/" title="Save Mission Creek Bridge">Save Mission Creek Bridge</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:46:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/07/sbnp-editorial-585x390.jpg" href="https://newspress.com/immigration-reform-must-start-with-secure-borders/" title="Immigration reform must start with secure borders">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/immigration-reform-must-start-with-secure-borders/" title="Immigration reform must start with secure borders">Immigration reform must start with secure borders</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:45:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/ed-buckley-032121-cropped.jpg" href="https://newspress.com/end-of-empire/" title="End of empire">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/end-of-empire/" title="End of empire">End of empire</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:44:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/07/sbnp-editorial-585x390.jpg" href="https://newspress.com/when-preservation-is-greed-by-another-name/" title="When preservation is greed by another name">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/when-preservation-is-greed-by-another-name/" title="When preservation is greed by another name">When preservation is greed by another name</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:43:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-8328" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-8328"><a href="https://newspress.com/category/life/"><b>Life</b></a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">				<div class="penci-mega-child-categories">
							<a class="mega-cat-child cat-active all-style"
				   href="https://newspress.com/category/life/"
				   data-id="penci-mega-24"><span>All</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/life/pets-of-the-week/"
				   data-id="penci-mega-3449"><span>PETS of the WEEK</span></a>
					</div>
		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
								<div class="penci-mega-row penci-mega-24 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lfw-ecuadora-2-033121-585x390.jpg" href="https://newspress.com/ecuadorian-cuisine/" title="Ecuadorian cuisine">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/ecuadorian-cuisine/" title="Ecuadorian cuisine">Ecuadorian cuisine</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:30:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lfw-filmfest-033121-585x390.jpg" href="https://newspress.com/santa-barbara-film-festival-begins-tonight/" title="Santa Barbara film festival begins tonight">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/santa-barbara-film-festival-begins-tonight/" title="Santa Barbara film festival begins tonight">Santa Barbara film festival begins tonight</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:29:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/07/sbnp-life-34-585x390.jpg" href="https://newspress.com/awc-sb-announces-awards/" title="AWC-SB announces awards">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/awc-sb-announces-awards/" title="AWC-SB announces awards">AWC-SB announces awards</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:28:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lfw-hospicespeaker-033121-cropped-299x390.png" href="https://newspress.com/hospice-to-feature-dr-sunita-puri/" title="Hospice to feature Dr. Sunita Puri">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/hospice-to-feature-dr-sunita-puri/" title="Hospice to feature Dr. Sunita Puri">Hospice to feature Dr. Sunita Puri</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:27:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3449">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lfw-petoftheweekcloud-032421-585x390.jpg" href="https://newspress.com/pet-of-the-week-26/" title="PET OF THE WEEK">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/pet-of-the-week-26/" title="PET OF THE WEEK">PET OF THE WEEK</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-24T05:42:00-07:00">March 24, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lfw-petoftheweekherbie-031721-480x390.jpg" href="https://newspress.com/pet-of-the-week-25/" title="PET OF THE WEEK">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/pet-of-the-week-25/" title="PET OF THE WEEK">PET OF THE WEEK</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-17T05:26:00-07:00">March 17, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lfw-petoftheweek-030321-585x390.jpg" href="https://newspress.com/pet-of-the-week-lanie/" title="PET OF THE WEEK : Lanie">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/pet-of-the-week-lanie/" title="PET OF THE WEEK : Lanie">PET OF THE WEEK : Lanie</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-03T05:34:15-08:00">March 3, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/01/lfw-petoftheweekbella-012721-585x390.jpg" href="https://newspress.com/pet-of-the-week-23/" title="PET OF THE WEEK">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/pet-of-the-week-23/" title="PET OF THE WEEK">PET OF THE WEEK</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-01-27T05:29:06-08:00">January 27, 2021</time></p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-18"><a href="https://newspress.com/category/sports/"><b>Sports</b></a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">				<div class="penci-mega-child-categories">
							<a class="mega-cat-child cat-active all-style"
				   href="https://newspress.com/category/sports/"
				   data-id="penci-mega-9"><span>All</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/sports/foresters/"
				   data-id="penci-mega-851"><span>Foresters</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/sports/highschoolsports/"
				   data-id="penci-mega-1610"><span>High School Sports</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/sports/sbcc-sports/"
				   data-id="penci-mega-852"><span>SBCC Sports</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/sports/ucsb-sports/"
				   data-id="penci-mega-850"><span>UCSB Sports</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/sports/westmont-sports/"
				   data-id="penci-mega-2921"><span>Westmont Sports</span></a>
					</div>
		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
								<div class="penci-mega-row penci-mega-9 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-collegenotebook-033121-cropped.jpg" href="https://newspress.com/college-notebook-jones-homecoming-leads-to-breakout-meet-in-heptathlon/" title="COLLEGE NOTEBOOK : Jones’ homecoming leads to breakout meet in heptathlon">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/college-notebook-jones-homecoming-leads-to-breakout-meet-in-heptathlon/" title="COLLEGE NOTEBOOK : Jones’ homecoming leads to breakout meet in heptathlon">COLLEGE NOTEBOOK : Jones’ homecoming leads to breakout&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:32:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/08/sbnp-sports-12-585x390.jpg" href="https://newspress.com/sports-roundup-carpinteria-football-game-canceled-by-positive-covid-19-test/" title="SPORTS ROUNDUP : Carpinteria football game canceled by positive COVID-19 test">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sports-roundup-carpinteria-football-game-canceled-by-positive-covid-19-test/" title="SPORTS ROUNDUP : Carpinteria football game canceled by positive COVID-19 test">SPORTS ROUNDUP : Carpinteria football game canceled by&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:31:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-basketball-0330211-cropped-585x390.jpg" href="https://newspress.com/gauchos-look-to-build-on-the-success-of-ncaa-tournament-run/" title="Gauchos look to build on the success of NCAA Tournament run">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/gauchos-look-to-build-on-the-success-of-ncaa-tournament-run/" title="Gauchos look to build on the success of NCAA Tournament run">Gauchos look to build on the success of&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-30T05:53:00-07:00">March 30, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/08/sbnp-sports-12-585x390.jpg" href="https://newspress.com/sports-roundup-westmonts-soccer-comeback-falls-short-against-azusa-pacific/" title="SPORTS ROUNDUP : Westmont’s soccer comeback falls short against Azusa Pacific">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sports-roundup-westmonts-soccer-comeback-falls-short-against-azusa-pacific/" title="SPORTS ROUNDUP : Westmont’s soccer comeback falls short against Azusa Pacific">SPORTS ROUNDUP : Westmont’s soccer comeback falls short&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-30T05:52:00-07:00">March 30, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-851">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/08/spw-Pintard-081920-e1597821443741-585x390.jpg" href="https://newspress.com/pintard-has-foresters-still-running-toward-glory-after-26-seasons/" title="Pintard has Foresters still running toward glory after 26 seasons">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/pintard-has-foresters-still-running-toward-glory-after-26-seasons/" title="Pintard has Foresters still running toward glory after 26 seasons">Pintard has Foresters still running toward glory after&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-08-19T05:52:00-07:00">August 19, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/08/lcw-forester001-0811-585x390.jpg" href="https://newspress.com/world-series-champions/" title="World Series champions">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/world-series-champions/" title="World Series champions">World Series champions</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-08-11T06:22:00-07:00">August 11, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/08/sbnp-sports-3-585x390.jpg" href="https://newspress.com/breaking-news-sb-foresters-win-world-series/" title="Breaking news: SB Foresters win World Series">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/breaking-news-sb-foresters-win-world-series/" title="Breaking news: SB Foresters win World Series">Breaking news: SB Foresters win World Series</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-08-10T22:44:44-07:00">August 10, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/07/santa-barbara-foresters-585x390.jpg" href="https://newspress.com/foresters-go-for-nbc-title-tonight/" title="Foresters go for NBC title tonight">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/foresters-go-for-nbc-title-tonight/" title="Foresters go for NBC title tonight">Foresters go for NBC title tonight</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-08-10T06:27:00-07:00">August 10, 2020</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-1610">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-sbsyfootball-032721-4-585x390.jpg" href="https://newspress.com/pirates-upend-dons-in-sbs-season-opener/" title="Pirates upend Dons in SB’s season opener">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/pirates-upend-dons-in-sbs-season-opener/" title="Pirates upend Dons in SB’s season opener">Pirates upend Dons in SB’s season opener</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-27T05:28:00-07:00">March 27, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-SMDPBaseball-032521-1-585x390.jpg" href="https://newspress.com/mandel-manhandles-dp-with-six-rbis-in-royals-20-4-romp/" title="Mandel manhandles DP with six RBIs in Royals’ 20-4 romp">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/mandel-manhandles-dp-with-six-rbis-in-royals-20-4-romp/" title="Mandel manhandles DP with six RBIs in Royals’ 20-4 romp">Mandel manhandles DP with six RBIs in Royals’&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-25T05:54:00-07:00">March 25, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-BishopDiego-032021-4-585x390.jpg" href="https://newspress.com/chans-late-touchdown-propels-cardinals-in-opener/" title="Chan’s late touchdown propels Cardinals in opener">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/chans-late-touchdown-propels-cardinals-in-opener/" title="Chan’s late touchdown propels Cardinals in opener">Chan’s late touchdown propels Cardinals in opener</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-20T05:45:00-07:00">March 20, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-hill-031921-585x390.jpg" href="https://newspress.com/dons-to-open-with-rival-royals-game-to-take-place-at-scene-of-last-seasons-cif-final/" title="Dons to open with rival Royals Game to take place at scene of last season’s CIF final">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/dons-to-open-with-rival-royals-game-to-take-place-at-scene-of-last-seasons-cif-final/" title="Dons to open with rival Royals Game to take place at scene of last season’s CIF final">Dons to open with rival Royals Game to&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-19T05:32:00-07:00">March 19, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-852">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/04/sbcc_lg_onwhite-585x390.jpg" href="https://newspress.com/sbcc-football-announces-new-team-doctor/" title="SBCC football announces new team doctor">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sbcc-football-announces-new-team-doctor/" title="SBCC football announces new team doctor">SBCC football announces new team doctor</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-01T05:31:00-08:00">March 1, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/01/spw-volleyballdyer-011921-1-480x390.jpg" href="https://newspress.com/vaqueros-name-dyer-as-new-head-coach-for-mens-volleyball/" title="Vaqueros name Dyer as new head coach for men’s volleyball">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/vaqueros-name-dyer-as-new-head-coach-for-mens-volleyball/" title="Vaqueros name Dyer as new head coach for men’s volleyball">Vaqueros name Dyer as new head coach for&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-01-19T05:25:48-08:00">January 19, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/12/spw-LaPlaya-122420-585x385.jpg" href="https://newspress.com/sbcc-trustees-vote-to-roll-out-the-green-carpet-at-la-playa-stadium/" title="SBCC trustees vote to roll out the green carpet at La Playa Stadium">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sbcc-trustees-vote-to-roll-out-the-green-carpet-at-la-playa-stadium/" title="SBCC trustees vote to roll out the green carpet at La Playa Stadium">SBCC trustees vote to roll out the green&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-12-24T05:54:22-08:00">December 24, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/12/spw-Moropoulos-120320-585x390.jpg" href="https://newspress.com/sbcc-to-cancel-seasons-for-10-sports/" title="SBCC to cancel seasons for 10 sports">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sbcc-to-cancel-seasons-for-10-sports/" title="SBCC to cancel seasons for 10 sports">SBCC to cancel seasons for 10 sports</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-12-03T05:59:47-08:00">December 3, 2020</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-850">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-basketball-0330211-cropped-585x390.jpg" href="https://newspress.com/gauchos-look-to-build-on-the-success-of-ncaa-tournament-run/" title="Gauchos look to build on the success of NCAA Tournament run">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/gauchos-look-to-build-on-the-success-of-ncaa-tournament-run/" title="Gauchos look to build on the success of NCAA Tournament run">Gauchos look to build on the success of&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-30T05:53:00-07:00">March 30, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-UCSBBaseball-032921-1-585x390.jpg" href="https://newspress.com/rodriguez-comes-up-huge-in-gauchos-win-over-davis/" title="Rodriguez comes up huge in Gauchos’ win over Davis">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/rodriguez-comes-up-huge-in-gauchos-win-over-davis/" title="Rodriguez comes up huge in Gauchos’ win over Davis">Rodriguez comes up huge in Gauchos’ win over&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:50:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-UCSBTennis-032921-1-585x390.jpg" href="https://newspress.com/ucsb-pounds-uc-riverside-in-tennis/" title="UCSB pounds UC Riverside in tennis">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/ucsb-pounds-uc-riverside-in-tennis/" title="UCSB pounds UC Riverside in tennis">UCSB pounds UC Riverside in tennis</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:49:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-mclaughlin-032621-cropped-585x390.jpg" href="https://newspress.com/mclaughlin-finds-more-treasure-at-the-end-of-his-gaucho-road/" title="McLaughlin finds more treasure at the end of his Gaucho road">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/mclaughlin-finds-more-treasure-at-the-end-of-his-gaucho-road/" title="McLaughlin finds more treasure at the end of his Gaucho road">McLaughlin finds more treasure at the end of&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-26T06:23:00-07:00">March 26, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-2921">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-warriors-032821-2-1-585x390.jpg" href="https://newspress.com/moore-berberabe-rise-to-the-head-of-the-class-in-the-naia/" title="Moore, Berberabe rise to the head of the class in the NAIA">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/moore-berberabe-rise-to-the-head-of-the-class-in-the-naia/" title="Moore, Berberabe rise to the head of the class in the NAIA">Moore, Berberabe rise to the head of the&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:53:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-jensen-032621-585x390.jpg" href="https://newspress.com/college-roundup-jensens-jolts-launch-westmont-to-double-header-sweep/" title="COLLEGE ROUNDUP : Jensen’s jolts launch Westmont to double-header sweep">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/college-roundup-jensens-jolts-launch-westmont-to-double-header-sweep/" title="COLLEGE ROUNDUP : Jensen’s jolts launch Westmont to double-header sweep">COLLEGE ROUNDUP : Jensen’s jolts launch Westmont to&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-26T06:22:00-07:00">March 26, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-westmontvolleyball-1-032421-585x390.jpg" href="https://newspress.com/pandemic-cant-keep-kerman-from-thriving-with-westmont-volleyball/" title="Pandemic can’t keep Kerman from thriving with Westmont volleyball">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/pandemic-cant-keep-kerman-from-thriving-with-westmont-volleyball/" title="Pandemic can’t keep Kerman from thriving with Westmont volleyball">Pandemic can’t keep Kerman from thriving with Westmont&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-24T05:51:00-07:00">March 24, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/08/sbnp-sports-local-roundup-3-585x390.jpg" href="https://newspress.com/sports-roundup-2/" title="SPORTS ROUNDUP">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sports-roundup-2/" title="SPORTS ROUNDUP">SPORTS ROUNDUP</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-18T05:47:00-07:00">March 18, 2021</time></p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-16207" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-16207"><a href="#"><b>Special Editions</b></a>
<ul class="sub-menu">
	<li id="menu-item-8236" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8236"><a target="_blank" href="https://issuu.com/sbnpvirtual/docs/retab_032821sm">House &#038; Home</a></li>
	<li id="menu-item-8233" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8233"><a target="_blank" href="https://issuu.com/sbnpvirtual/docs/smartclips_030321">SmartClips</a></li>
	<li id="menu-item-24780" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24780"><a target="_blank" href="https://issuu.com/sbnpvirtual/docs/web_20vet_20page_111120">Tribute to Armed Forces</a></li>
	<li id="menu-item-18216" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18216"><a target="_blank" href="https://issuu.com/sbnpvirtual/docs/back_to_business">Back to Business</a></li>
	<li id="menu-item-16294" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16294"><a target="_blank" href="https://issuu.com/sbnpvirtual/docs/spe_052420">Open for Business</a></li>
	<li id="menu-item-14302" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14302"><a target="_blank" href="https://issuu.com/sbnpvirtual/docs/restaurant-guide-032920?fr=sNGYxZDEwOTQxNDQ">Restaurant Guide</a></li>
	<li id="menu-item-8234" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8234"><a target="_blank" href="https://issuu.com/sbnpvirtual/docs/readerschoice2019">Readers&#8217; Choice</a></li>
</ul>
</li>
<li id="menu-item-22902" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children penci-mega-menu menu-item-22902"><a href="https://newspress.com/category/obituaries/">Obituaries</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">				<div class="penci-mega-child-categories">
							<a class="mega-cat-child cat-active all-style"
				   href="https://newspress.com/category/obituaries/"
				   data-id="penci-mega-13"><span>All</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/obituaries/celebration-of-life/"
				   data-id="penci-mega-3231"><span>Celebration of Life</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/obituaries/in-memorium/"
				   data-id="penci-mega-3230"><span>In Memorium</span></a>
					</div>
		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
								<div class="penci-mega-row penci-mega-13 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/o_Sims-033121-_2.jpg" href="https://newspress.com/sims-hannah-elizabeth/" title="SIMS, Hannah Elizabeth">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sims-hannah-elizabeth/" title="SIMS, Hannah Elizabeth">SIMS, Hannah Elizabeth</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T00:00:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/08/Obits_noimageavailable-e1596584610295.jpg" href="https://newspress.com/kistler-william-h/" title="KISTLER, William H.">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/kistler-william-h/" title="KISTLER, William H.">KISTLER, William H.</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-30T00:00:00-07:00">March 30, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/o_Hale032821.jpg" href="https://newspress.com/hale-thomas-iii/" title="HALE, Thomas, III">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/hale-thomas-iii/" title="HALE, Thomas, III">HALE, Thomas, III</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T00:00:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/o_Johnson032821.jpg" href="https://newspress.com/johnson-mary-luella-tucker/" title="JOHNSON, Mary Luella (Tucker)">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/johnson-mary-luella-tucker/" title="JOHNSON, Mary Luella (Tucker)">JOHNSON, Mary Luella (Tucker)</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T00:00:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3231">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/09/c_MICHAEL_WIlliam.jpg" href="https://newspress.com/michael-william-ray/" title="MICHAEL, WILLIAM RAY">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/michael-william-ray/" title="MICHAEL, WILLIAM RAY">MICHAEL, WILLIAM RAY</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2019-03-07T11:14:57-08:00">March 7, 2019</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/08/Obits_noimageavailable-e1596584610295.jpg" href="https://newspress.com/muriel-ghormley-krebs-memorial/" title="Muriel Ghormley Krebs Memorial">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/muriel-ghormley-krebs-memorial/" title="Muriel Ghormley Krebs Memorial">Muriel Ghormley Krebs Memorial</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2014-01-08T12:46:00-08:00">January 8, 2014</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/themes/soledad/images/no-image.jpg" href="https://newspress.com/ervin-g-birzer/" title="Ervin G. Birzer">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/ervin-g-birzer/" title="Ervin G. Birzer">Ervin G. Birzer</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2013-06-23T16:27:27-07:00">June 23, 2013</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/themes/soledad/images/no-image.jpg" href="https://newspress.com/adela-ward/" title="ADELA  WARD">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/adela-ward/" title="ADELA  WARD">ADELA WARD</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2013-06-11T15:16:53-07:00">June 11, 2013</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3230">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/08/Obits_noimageavailable-e1596584610295.jpg" href="https://newspress.com/frank-papa-holguin/" title="FRANK &#8220;PAPA&#8221; HOLGUIN">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/frank-papa-holguin/" title="FRANK &#8220;PAPA&#8221; HOLGUIN">FRANK &#8220;PAPA&#8221; HOLGUIN</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-14T00:00:00-08:00">March 14, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/m_Saucedo090721.jpg" href="https://newspress.com/alejandro-alex-saucedo/" title="ALEJANDRO &#8220;ALEX&#8221; SAUCEDO">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/alejandro-alex-saucedo/" title="ALEJANDRO &#8220;ALEX&#8221; SAUCEDO">ALEJANDRO &#8220;ALEX&#8221; SAUCEDO</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-07T00:00:00-08:00">March 7, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/02/m_Gathercole022821.jpg" href="https://newspress.com/jon-gathercole-2/" title="JON GATHERCOLE">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/jon-gathercole-2/" title="JON GATHERCOLE">JON GATHERCOLE</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-02-28T00:00:18-08:00">February 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/02/m_Carmona-In-Memory021821.jpg" href="https://newspress.com/mavis-carmona-rosales/" title="MAVIS CARMONA (ROSALES)">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/mavis-carmona-rosales/" title="MAVIS CARMONA (ROSALES)">MAVIS CARMONA (ROSALES)</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-02-18T00:00:10-08:00">February 18, 2021</time></p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
	<li id="menu-item-22906" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22906"><a href="https://newspress.com/place-an-obituary/">Place An Obituary</a></li>
</ul>
</li>
<li id="menu-item-8238" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8238"><a target="_blank" href="http://174.127.32.54/Top/Search/advancedSearch.jsp">Archives</a></li>
<li id="menu-item-22903" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-22903"><a href="#">Resources</a>
<ul class="sub-menu">
	<li id="menu-item-22904" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22904"><a target="_blank" href="https://newspress.com/employment/">Employment</a></li>
	<li id="menu-item-22905" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22905"><a href="https://newspress.com/photo-reprint-request-form/">Photo Reprints</a></li>
	<li id="menu-item-22907" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22907"><a href="https://newspress.com/advertising/">Place An Ad</a></li>
	<li id="menu-item-22908" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22908"><a href="https://newspress.com/how-to-place-celebration-announcements/">Place A Celebration Announcement</a></li>
	<li id="menu-item-23293" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23293"><a target="_blank" href="http://morenews.newspress.com/kzsb/player.html">KZSB News-Press Radio</a></li>
</ul>
</li>
<li id="menu-item-20970" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20970"><a href="https://newspress.com/login/">Login</a></li>
<li id="menu-item-20971" class="subscribe-menu menu-item menu-item-type-custom menu-item-object-custom menu-item-20971"><a href="https://newspress.com/subscribe">SUBSCRIBE</a></li>
</ul>	</nav>
<div class="wrapper-boxed header-style-header-2">
<div class="penci-header-wrap"><header id="header" class="header-header-2 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
			<div class="inner-header penci-header-second">
			<div class="container">
				<div id="logo">
					<a href="https://newspress.com/"><img src="https://newspress.com//////wp-content/uploads/2019/03/sbnp-logo-with-bldg500.png" alt="Santa Barbara News-Press"/></a>									</div>

				
							</div>
		</div>
								<nav id="navigation" class="header-layout-bottom header-2 menu-style-1" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
			<div class="container">
				<div class="button-menu-mobile header-2"><i class="penci-faicon fa fa-bars" ></i></div>
				<ul id="menu-sections-1" class="menu"><li class="multi-line menu-item menu-item-type-custom menu-item-object-custom menu-item-8231"><a target="_blank" href="https://issuu.com/sbnpvirtual"><b>Virtual Edition</b></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-15"><a href="https://newspress.com/category/local/"><b>Local</b></a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">				<div class="penci-mega-child-categories">
							<a class="mega-cat-child cat-active all-style"
				   href="https://newspress.com/category/local/"
				   data-id="penci-mega-8"><span>All</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/celebrations/"
				   data-id="penci-mega-3452"><span>Celebrations</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/coronavirus-pandemic-2020/"
				   data-id="penci-mega-2920"><span>Coronavirus Pandemic 2020</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/death-notices/"
				   data-id="penci-mega-3450"><span>Death Notices</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/election/"
				   data-id="penci-mega-3462"><span>Election</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/news-brief/"
				   data-id="penci-mega-3448"><span>News Brief</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/traffic-crime-blotter/"
				   data-id="penci-mega-3451"><span>Traffic &amp; Crime Blotter</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/voices/"
				   data-id="penci-mega-10"><span>Voices</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/local/voices/opinions-letters/"
				   data-id="penci-mega-11"><span>Opinions-Letters</span></a>
					</div>
		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
								<div class="penci-mega-row penci-mega-8 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lcw-hiking-033121-1-585x390.jpg" href="https://newspress.com/enjoying-sbs-beauty/" title="Enjoying SB’s beauty">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/enjoying-sbs-beauty/" title="Enjoying SB’s beauty">Enjoying SB’s beauty</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T06:00:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lcw-mailes-033121-585x390.jpg" href="https://newspress.com/mailes-appointed-as-new-fire-chief/" title="Mailes appointed as new fire chief">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/mailes-appointed-as-new-fire-chief/" title="Mailes appointed as new fire chief">Mailes appointed as new fire chief</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:59:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lcw-MagicCastle-033121-1-585x390.jpg" href="https://newspress.com/larsens-to-sell-magic-castle-cabaret/" title="Larsens to sell Magic Castle Cabaret">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/larsens-to-sell-magic-castle-cabaret/" title="Larsens to sell Magic Castle Cabaret">Larsens to sell Magic Castle Cabaret</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:58:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/06/santa-barbara-newspress-local-news.jpg" href="https://newspress.com/united-way-offers-millions-in-rent-relief/" title="United Way offers millions in rent relief">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/united-way-offers-millions-in-rent-relief/" title="United Way offers millions in rent relief">United Way offers millions in rent relief</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:57:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3452">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/12/c_Andersson122020-e1608244434405.jpg" href="https://newspress.com/celebrations-12-20-20/" title="Celebrations: 12-20-20">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/celebrations-12-20-20/" title="Celebrations: 12-20-20">Celebrations: 12-20-20</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-12-20T05:00:11-08:00">December 20, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/11/c_Tovar2_112220-e1605900724282.jpg" href="https://newspress.com/celebrations-11-22-20/" title="Celebrations: 11-22-20">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/celebrations-11-22-20/" title="Celebrations: 11-22-20">Celebrations: 11-22-20</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-11-22T05:00:59-08:00">November 22, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/10/c_Mercado1_102520-e1603485600734.jpg" href="https://newspress.com/celebrations-10-25-20-2/" title="Celebrations: 10-25-20">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/celebrations-10-25-20-2/" title="Celebrations: 10-25-20">Celebrations: 10-25-20</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-10-25T05:01:00-07:00">October 25, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/10/c_Spiro102520-e1603485241577.jpg" href="https://newspress.com/celebrations-10-25-20/" title="Celebrations: 10-25-20">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/celebrations-10-25-20/" title="Celebrations: 10-25-20">Celebrations: 10-25-20</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-10-25T05:00:00-07:00">October 25, 2020</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-2920">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/03/coronavirus-cellular-picture-585x390.jpg" href="https://newspress.com/sb-county-reports-30-covid-19-cases-two-deaths/" title="SB County reports 30 COVID-19 cases, two deaths">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sb-county-reports-30-covid-19-cases-two-deaths/" title="SB County reports 30 COVID-19 cases, two deaths">SB County reports 30 COVID-19 cases, two deaths</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:55:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/03/coronavirus-cellular-picture-585x390.jpg" href="https://newspress.com/county-reports-29-covid-19-cases-one-death/" title="County reports 29 COVID-19 cases, one death">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/county-reports-29-covid-19-cases-one-death/" title="County reports 29 COVID-19 cases, one death">County reports 29 COVID-19 cases, one death</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-30T05:57:00-07:00">March 30, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/03/coronavirus-santa-barbara-county-585x390.jpg" href="https://newspress.com/santa-barbara-county-reports-32-covid-19-cases/" title="Santa Barbara County reports 32 COVID-19 cases">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/santa-barbara-county-reports-32-covid-19-cases/" title="Santa Barbara County reports 32 COVID-19 cases">Santa Barbara County reports 32 COVID-19 cases</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:48:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/03/coronavirus-cellular-picture-585x390.jpg" href="https://newspress.com/santa-barbara-county-confirms-26-new-covid-19-cases/" title="Santa Barbara County confirms 26 new COVID-19 cases">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/santa-barbara-county-confirms-26-new-covid-19-cases/" title="Santa Barbara County confirms 26 new COVID-19 cases">Santa Barbara County confirms 26 new COVID-19 cases</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:54:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3450">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/09/santa-barbara-newspress-death-notice-4-585x390.jpg" href="https://newspress.com/death-notice-25/" title="DEATH NOTICE">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/death-notice-25/" title="DEATH NOTICE">DEATH NOTICE</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-27T05:52:00-07:00">March 27, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/09/santa-barbara-newspress-death-notice-4-585x390.jpg" href="https://newspress.com/death-notice-24/" title="DEATH NOTICE">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/death-notice-24/" title="DEATH NOTICE">DEATH NOTICE</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-22T06:03:00-07:00">March 22, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/09/santa-barbara-newspress-death-notice-4-585x390.jpg" href="https://newspress.com/death-notices-28/" title="DEATH NOTICES">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/death-notices-28/" title="DEATH NOTICES">DEATH NOTICES</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-14T05:55:00-07:00">March 14, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/09/santa-barbara-newspress-death-notice-4-585x390.jpg" href="https://newspress.com/death-notice-23/" title="DEATH NOTICE">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/death-notice-23/" title="DEATH NOTICE">DEATH NOTICE</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-11T05:52:00-08:00">March 11, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3462">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/11/lcw-TrumpBiden-100120-1-e1605161812108-585x345.jpg" href="https://newspress.com/locals-discuss-voter-fraud-allegations/" title="Locals discuss voter fraud allegations">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/locals-discuss-voter-fraud-allegations/" title="Locals discuss voter fraud allegations">Locals discuss voter fraud allegations</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-11-12T05:59:37-08:00">November 12, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/11/lcw-Biden-110720-585x390.jpg" href="https://newspress.com/biden-declared-winner/" title="UPDATED: Biden declared winner, calls for unity">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/biden-declared-winner/" title="UPDATED: Biden declared winner, calls for unity">UPDATED: Biden declared winner, calls for unity</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-11-07T09:53:38-08:00">November 7, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/11/lcw-TrumpBiden-100120-585x390.jpg" href="https://newspress.com/local-republicans-democrats-remain-optimistic/" title="Local Republicans, Democrats remain optimistic">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/local-republicans-democrats-remain-optimistic/" title="Local Republicans, Democrats remain optimistic">Local Republicans, Democrats remain optimistic</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-11-05T05:59:00-08:00">November 5, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/11/lcw-ColdSprings-110520-585x390.jpg" href="https://newspress.com/school-measures-board-races-remain-tight/" title="School measures, board races remain tight">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/school-measures-board-races-remain-tight/" title="School measures, board races remain tight">School measures, board races remain tight</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-11-05T05:58:00-08:00">November 5, 2020</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3448">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/07/lcw-Library-070219-141-585x390.jpg" href="https://newspress.com/santa-barbara-library-sponsors-reading-program/" title="Santa Barbara Library sponsors reading program">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/santa-barbara-library-sponsors-reading-program/" title="Santa Barbara Library sponsors reading program">Santa Barbara Library sponsors reading program</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:56:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/06/santa-barbara-newspress-local-news.jpg" href="https://newspress.com/sm-main-library-reopens-for-short-visits/" title="SM main library reopens for short visits">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sm-main-library-reopens-for-short-visits/" title="SM main library reopens for short visits">SM main library reopens for short visits</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:55:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/04/caltrans-logo-585x390.png" href="https://newspress.com/funds-allocated-for-transportation-improvements/" title="Funds allocated for transportation improvements">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/funds-allocated-for-transportation-improvements/" title="Funds allocated for transportation improvements">Funds allocated for transportation improvements</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:54:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/06/santa-barbara-newspress-local-news.jpg" href="https://newspress.com/naturetrack-leads-hike-for-grandparents-and-grandchildren/" title="NatureTrack leads hike for grandparents and grandchildren">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/naturetrack-leads-hike-for-grandparents-and-grandchildren/" title="NatureTrack leads hike for grandparents and grandchildren">NatureTrack leads hike for grandparents and grandchildren</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:53:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3451">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/09/Santa-Barbara-News-Press-Crime-2-585x390.jpg" href="https://newspress.com/traffic-crime-and-fire-blotter-137/" title="Traffic, Crime and Fire Blotter">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/traffic-crime-and-fire-blotter-137/" title="Traffic, Crime and Fire Blotter">Traffic, Crime and Fire Blotter</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:54:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/09/Santa-Barbara-News-Press-Crime-2-585x390.jpg" href="https://newspress.com/traffic-crime-and-fire-blotter-136/" title="Traffic, Crime and Fire Blotter">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/traffic-crime-and-fire-blotter-136/" title="Traffic, Crime and Fire Blotter">Traffic, Crime and Fire Blotter</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-30T05:56:00-07:00">March 30, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lcw-blotter-032921-1-e1617003046848-585x390.jpg" href="https://newspress.com/traffic-crime-and-fire-blotter-135/" title="Traffic, Crime and Fire Blotter">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/traffic-crime-and-fire-blotter-135/" title="Traffic, Crime and Fire Blotter">Traffic, Crime and Fire Blotter</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:57:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lcw-blotter-032821-1-1-585x390.jpg" href="https://newspress.com/traffic-crime-and-fire-blotter-134/" title="Traffic, Crime and Fire Blotter">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/traffic-crime-and-fire-blotter-134/" title="Traffic, Crime and Fire Blotter">Traffic, Crime and Fire Blotter</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:57:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-10">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/ed-MissionCreek-032821-585x390.jpg" href="https://newspress.com/save-mission-creek-bridge/" title="Save Mission Creek Bridge">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/save-mission-creek-bridge/" title="Save Mission Creek Bridge">Save Mission Creek Bridge</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:46:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/07/sbnp-editorial-585x390.jpg" href="https://newspress.com/immigration-reform-must-start-with-secure-borders/" title="Immigration reform must start with secure borders">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/immigration-reform-must-start-with-secure-borders/" title="Immigration reform must start with secure borders">Immigration reform must start with secure borders</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:45:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/ed-buckley-032121-cropped.jpg" href="https://newspress.com/end-of-empire/" title="End of empire">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/end-of-empire/" title="End of empire">End of empire</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:44:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/07/sbnp-editorial-585x390.jpg" href="https://newspress.com/when-preservation-is-greed-by-another-name/" title="When preservation is greed by another name">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/when-preservation-is-greed-by-another-name/" title="When preservation is greed by another name">When preservation is greed by another name</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:43:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-11">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/ed-MissionCreek-032821-585x390.jpg" href="https://newspress.com/save-mission-creek-bridge/" title="Save Mission Creek Bridge">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/save-mission-creek-bridge/" title="Save Mission Creek Bridge">Save Mission Creek Bridge</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:46:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/07/sbnp-editorial-585x390.jpg" href="https://newspress.com/immigration-reform-must-start-with-secure-borders/" title="Immigration reform must start with secure borders">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/immigration-reform-must-start-with-secure-borders/" title="Immigration reform must start with secure borders">Immigration reform must start with secure borders</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:45:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/ed-buckley-032121-cropped.jpg" href="https://newspress.com/end-of-empire/" title="End of empire">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/end-of-empire/" title="End of empire">End of empire</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:44:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/07/sbnp-editorial-585x390.jpg" href="https://newspress.com/when-preservation-is-greed-by-another-name/" title="When preservation is greed by another name">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/when-preservation-is-greed-by-another-name/" title="When preservation is greed by another name">When preservation is greed by another name</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:43:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-8328"><a href="https://newspress.com/category/life/"><b>Life</b></a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">				<div class="penci-mega-child-categories">
							<a class="mega-cat-child cat-active all-style"
				   href="https://newspress.com/category/life/"
				   data-id="penci-mega-24"><span>All</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/life/pets-of-the-week/"
				   data-id="penci-mega-3449"><span>PETS of the WEEK</span></a>
					</div>
		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
								<div class="penci-mega-row penci-mega-24 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lfw-ecuadora-2-033121-585x390.jpg" href="https://newspress.com/ecuadorian-cuisine/" title="Ecuadorian cuisine">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/ecuadorian-cuisine/" title="Ecuadorian cuisine">Ecuadorian cuisine</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:30:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lfw-filmfest-033121-585x390.jpg" href="https://newspress.com/santa-barbara-film-festival-begins-tonight/" title="Santa Barbara film festival begins tonight">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/santa-barbara-film-festival-begins-tonight/" title="Santa Barbara film festival begins tonight">Santa Barbara film festival begins tonight</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:29:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/07/sbnp-life-34-585x390.jpg" href="https://newspress.com/awc-sb-announces-awards/" title="AWC-SB announces awards">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/awc-sb-announces-awards/" title="AWC-SB announces awards">AWC-SB announces awards</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:28:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lfw-hospicespeaker-033121-cropped-299x390.png" href="https://newspress.com/hospice-to-feature-dr-sunita-puri/" title="Hospice to feature Dr. Sunita Puri">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/hospice-to-feature-dr-sunita-puri/" title="Hospice to feature Dr. Sunita Puri">Hospice to feature Dr. Sunita Puri</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:27:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3449">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lfw-petoftheweekcloud-032421-585x390.jpg" href="https://newspress.com/pet-of-the-week-26/" title="PET OF THE WEEK">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/pet-of-the-week-26/" title="PET OF THE WEEK">PET OF THE WEEK</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-24T05:42:00-07:00">March 24, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lfw-petoftheweekherbie-031721-480x390.jpg" href="https://newspress.com/pet-of-the-week-25/" title="PET OF THE WEEK">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/pet-of-the-week-25/" title="PET OF THE WEEK">PET OF THE WEEK</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-17T05:26:00-07:00">March 17, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/lfw-petoftheweek-030321-585x390.jpg" href="https://newspress.com/pet-of-the-week-lanie/" title="PET OF THE WEEK : Lanie">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/pet-of-the-week-lanie/" title="PET OF THE WEEK : Lanie">PET OF THE WEEK : Lanie</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-03T05:34:15-08:00">March 3, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/01/lfw-petoftheweekbella-012721-585x390.jpg" href="https://newspress.com/pet-of-the-week-23/" title="PET OF THE WEEK">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/pet-of-the-week-23/" title="PET OF THE WEEK">PET OF THE WEEK</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-01-27T05:29:06-08:00">January 27, 2021</time></p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-18"><a href="https://newspress.com/category/sports/"><b>Sports</b></a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">				<div class="penci-mega-child-categories">
							<a class="mega-cat-child cat-active all-style"
				   href="https://newspress.com/category/sports/"
				   data-id="penci-mega-9"><span>All</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/sports/foresters/"
				   data-id="penci-mega-851"><span>Foresters</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/sports/highschoolsports/"
				   data-id="penci-mega-1610"><span>High School Sports</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/sports/sbcc-sports/"
				   data-id="penci-mega-852"><span>SBCC Sports</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/sports/ucsb-sports/"
				   data-id="penci-mega-850"><span>UCSB Sports</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/sports/westmont-sports/"
				   data-id="penci-mega-2921"><span>Westmont Sports</span></a>
					</div>
		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
								<div class="penci-mega-row penci-mega-9 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-collegenotebook-033121-cropped.jpg" href="https://newspress.com/college-notebook-jones-homecoming-leads-to-breakout-meet-in-heptathlon/" title="COLLEGE NOTEBOOK : Jones’ homecoming leads to breakout meet in heptathlon">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/college-notebook-jones-homecoming-leads-to-breakout-meet-in-heptathlon/" title="COLLEGE NOTEBOOK : Jones’ homecoming leads to breakout meet in heptathlon">COLLEGE NOTEBOOK : Jones’ homecoming leads to breakout&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:32:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/08/sbnp-sports-12-585x390.jpg" href="https://newspress.com/sports-roundup-carpinteria-football-game-canceled-by-positive-covid-19-test/" title="SPORTS ROUNDUP : Carpinteria football game canceled by positive COVID-19 test">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sports-roundup-carpinteria-football-game-canceled-by-positive-covid-19-test/" title="SPORTS ROUNDUP : Carpinteria football game canceled by positive COVID-19 test">SPORTS ROUNDUP : Carpinteria football game canceled by&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T05:31:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-basketball-0330211-cropped-585x390.jpg" href="https://newspress.com/gauchos-look-to-build-on-the-success-of-ncaa-tournament-run/" title="Gauchos look to build on the success of NCAA Tournament run">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/gauchos-look-to-build-on-the-success-of-ncaa-tournament-run/" title="Gauchos look to build on the success of NCAA Tournament run">Gauchos look to build on the success of&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-30T05:53:00-07:00">March 30, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/08/sbnp-sports-12-585x390.jpg" href="https://newspress.com/sports-roundup-westmonts-soccer-comeback-falls-short-against-azusa-pacific/" title="SPORTS ROUNDUP : Westmont’s soccer comeback falls short against Azusa Pacific">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sports-roundup-westmonts-soccer-comeback-falls-short-against-azusa-pacific/" title="SPORTS ROUNDUP : Westmont’s soccer comeback falls short against Azusa Pacific">SPORTS ROUNDUP : Westmont’s soccer comeback falls short&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-30T05:52:00-07:00">March 30, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-851">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/08/spw-Pintard-081920-e1597821443741-585x390.jpg" href="https://newspress.com/pintard-has-foresters-still-running-toward-glory-after-26-seasons/" title="Pintard has Foresters still running toward glory after 26 seasons">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/pintard-has-foresters-still-running-toward-glory-after-26-seasons/" title="Pintard has Foresters still running toward glory after 26 seasons">Pintard has Foresters still running toward glory after&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-08-19T05:52:00-07:00">August 19, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/08/lcw-forester001-0811-585x390.jpg" href="https://newspress.com/world-series-champions/" title="World Series champions">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/world-series-champions/" title="World Series champions">World Series champions</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-08-11T06:22:00-07:00">August 11, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/08/sbnp-sports-3-585x390.jpg" href="https://newspress.com/breaking-news-sb-foresters-win-world-series/" title="Breaking news: SB Foresters win World Series">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/breaking-news-sb-foresters-win-world-series/" title="Breaking news: SB Foresters win World Series">Breaking news: SB Foresters win World Series</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-08-10T22:44:44-07:00">August 10, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/07/santa-barbara-foresters-585x390.jpg" href="https://newspress.com/foresters-go-for-nbc-title-tonight/" title="Foresters go for NBC title tonight">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/foresters-go-for-nbc-title-tonight/" title="Foresters go for NBC title tonight">Foresters go for NBC title tonight</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-08-10T06:27:00-07:00">August 10, 2020</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-1610">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-sbsyfootball-032721-4-585x390.jpg" href="https://newspress.com/pirates-upend-dons-in-sbs-season-opener/" title="Pirates upend Dons in SB’s season opener">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/pirates-upend-dons-in-sbs-season-opener/" title="Pirates upend Dons in SB’s season opener">Pirates upend Dons in SB’s season opener</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-27T05:28:00-07:00">March 27, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-SMDPBaseball-032521-1-585x390.jpg" href="https://newspress.com/mandel-manhandles-dp-with-six-rbis-in-royals-20-4-romp/" title="Mandel manhandles DP with six RBIs in Royals’ 20-4 romp">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/mandel-manhandles-dp-with-six-rbis-in-royals-20-4-romp/" title="Mandel manhandles DP with six RBIs in Royals’ 20-4 romp">Mandel manhandles DP with six RBIs in Royals’&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-25T05:54:00-07:00">March 25, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-BishopDiego-032021-4-585x390.jpg" href="https://newspress.com/chans-late-touchdown-propels-cardinals-in-opener/" title="Chan’s late touchdown propels Cardinals in opener">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/chans-late-touchdown-propels-cardinals-in-opener/" title="Chan’s late touchdown propels Cardinals in opener">Chan’s late touchdown propels Cardinals in opener</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-20T05:45:00-07:00">March 20, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-hill-031921-585x390.jpg" href="https://newspress.com/dons-to-open-with-rival-royals-game-to-take-place-at-scene-of-last-seasons-cif-final/" title="Dons to open with rival Royals Game to take place at scene of last season’s CIF final">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/dons-to-open-with-rival-royals-game-to-take-place-at-scene-of-last-seasons-cif-final/" title="Dons to open with rival Royals Game to take place at scene of last season’s CIF final">Dons to open with rival Royals Game to&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-19T05:32:00-07:00">March 19, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-852">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/04/sbcc_lg_onwhite-585x390.jpg" href="https://newspress.com/sbcc-football-announces-new-team-doctor/" title="SBCC football announces new team doctor">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sbcc-football-announces-new-team-doctor/" title="SBCC football announces new team doctor">SBCC football announces new team doctor</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-01T05:31:00-08:00">March 1, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/01/spw-volleyballdyer-011921-1-480x390.jpg" href="https://newspress.com/vaqueros-name-dyer-as-new-head-coach-for-mens-volleyball/" title="Vaqueros name Dyer as new head coach for men’s volleyball">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/vaqueros-name-dyer-as-new-head-coach-for-mens-volleyball/" title="Vaqueros name Dyer as new head coach for men’s volleyball">Vaqueros name Dyer as new head coach for&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-01-19T05:25:48-08:00">January 19, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/12/spw-LaPlaya-122420-585x385.jpg" href="https://newspress.com/sbcc-trustees-vote-to-roll-out-the-green-carpet-at-la-playa-stadium/" title="SBCC trustees vote to roll out the green carpet at La Playa Stadium">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sbcc-trustees-vote-to-roll-out-the-green-carpet-at-la-playa-stadium/" title="SBCC trustees vote to roll out the green carpet at La Playa Stadium">SBCC trustees vote to roll out the green&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-12-24T05:54:22-08:00">December 24, 2020</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/12/spw-Moropoulos-120320-585x390.jpg" href="https://newspress.com/sbcc-to-cancel-seasons-for-10-sports/" title="SBCC to cancel seasons for 10 sports">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sbcc-to-cancel-seasons-for-10-sports/" title="SBCC to cancel seasons for 10 sports">SBCC to cancel seasons for 10 sports</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2020-12-03T05:59:47-08:00">December 3, 2020</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-850">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-basketball-0330211-cropped-585x390.jpg" href="https://newspress.com/gauchos-look-to-build-on-the-success-of-ncaa-tournament-run/" title="Gauchos look to build on the success of NCAA Tournament run">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/gauchos-look-to-build-on-the-success-of-ncaa-tournament-run/" title="Gauchos look to build on the success of NCAA Tournament run">Gauchos look to build on the success of&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-30T05:53:00-07:00">March 30, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-UCSBBaseball-032921-1-585x390.jpg" href="https://newspress.com/rodriguez-comes-up-huge-in-gauchos-win-over-davis/" title="Rodriguez comes up huge in Gauchos’ win over Davis">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/rodriguez-comes-up-huge-in-gauchos-win-over-davis/" title="Rodriguez comes up huge in Gauchos’ win over Davis">Rodriguez comes up huge in Gauchos’ win over&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:50:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-UCSBTennis-032921-1-585x390.jpg" href="https://newspress.com/ucsb-pounds-uc-riverside-in-tennis/" title="UCSB pounds UC Riverside in tennis">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/ucsb-pounds-uc-riverside-in-tennis/" title="UCSB pounds UC Riverside in tennis">UCSB pounds UC Riverside in tennis</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-29T05:49:00-07:00">March 29, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-mclaughlin-032621-cropped-585x390.jpg" href="https://newspress.com/mclaughlin-finds-more-treasure-at-the-end-of-his-gaucho-road/" title="McLaughlin finds more treasure at the end of his Gaucho road">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/mclaughlin-finds-more-treasure-at-the-end-of-his-gaucho-road/" title="McLaughlin finds more treasure at the end of his Gaucho road">McLaughlin finds more treasure at the end of&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-26T06:23:00-07:00">March 26, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-2921">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-warriors-032821-2-1-585x390.jpg" href="https://newspress.com/moore-berberabe-rise-to-the-head-of-the-class-in-the-naia/" title="Moore, Berberabe rise to the head of the class in the NAIA">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/moore-berberabe-rise-to-the-head-of-the-class-in-the-naia/" title="Moore, Berberabe rise to the head of the class in the NAIA">Moore, Berberabe rise to the head of the&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T05:53:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-jensen-032621-585x390.jpg" href="https://newspress.com/college-roundup-jensens-jolts-launch-westmont-to-double-header-sweep/" title="COLLEGE ROUNDUP : Jensen’s jolts launch Westmont to double-header sweep">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/college-roundup-jensens-jolts-launch-westmont-to-double-header-sweep/" title="COLLEGE ROUNDUP : Jensen’s jolts launch Westmont to double-header sweep">COLLEGE ROUNDUP : Jensen’s jolts launch Westmont to&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-26T06:22:00-07:00">March 26, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-westmontvolleyball-1-032421-585x390.jpg" href="https://newspress.com/pandemic-cant-keep-kerman-from-thriving-with-westmont-volleyball/" title="Pandemic can’t keep Kerman from thriving with Westmont volleyball">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/pandemic-cant-keep-kerman-from-thriving-with-westmont-volleyball/" title="Pandemic can’t keep Kerman from thriving with Westmont volleyball">Pandemic can’t keep Kerman from thriving with Westmont&#8230;</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-24T05:51:00-07:00">March 24, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2019/08/sbnp-sports-local-roundup-3-585x390.jpg" href="https://newspress.com/sports-roundup-2/" title="SPORTS ROUNDUP">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sports-roundup-2/" title="SPORTS ROUNDUP">SPORTS ROUNDUP</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-18T05:47:00-07:00">March 18, 2021</time></p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-16207"><a href="#"><b>Special Editions</b></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8236"><a target="_blank" href="https://issuu.com/sbnpvirtual/docs/retab_032821sm">House &#038; Home</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8233"><a target="_blank" href="https://issuu.com/sbnpvirtual/docs/smartclips_030321">SmartClips</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24780"><a target="_blank" href="https://issuu.com/sbnpvirtual/docs/web_20vet_20page_111120">Tribute to Armed Forces</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18216"><a target="_blank" href="https://issuu.com/sbnpvirtual/docs/back_to_business">Back to Business</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16294"><a target="_blank" href="https://issuu.com/sbnpvirtual/docs/spe_052420">Open for Business</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14302"><a target="_blank" href="https://issuu.com/sbnpvirtual/docs/restaurant-guide-032920?fr=sNGYxZDEwOTQxNDQ">Restaurant Guide</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8234"><a target="_blank" href="https://issuu.com/sbnpvirtual/docs/readerschoice2019">Readers&#8217; Choice</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children penci-mega-menu menu-item-22902"><a href="https://newspress.com/category/obituaries/">Obituaries</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">				<div class="penci-mega-child-categories">
							<a class="mega-cat-child cat-active all-style"
				   href="https://newspress.com/category/obituaries/"
				   data-id="penci-mega-13"><span>All</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/obituaries/celebration-of-life/"
				   data-id="penci-mega-3231"><span>Celebration of Life</span></a>
							<a class="mega-cat-child"
				   href="https://newspress.com/category/obituaries/in-memorium/"
				   data-id="penci-mega-3230"><span>In Memorium</span></a>
					</div>
		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
								<div class="penci-mega-row penci-mega-13 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/o_Sims-033121-_2.jpg" href="https://newspress.com/sims-hannah-elizabeth/" title="SIMS, Hannah Elizabeth">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/sims-hannah-elizabeth/" title="SIMS, Hannah Elizabeth">SIMS, Hannah Elizabeth</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-31T00:00:00-07:00">March 31, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/08/Obits_noimageavailable-e1596584610295.jpg" href="https://newspress.com/kistler-william-h/" title="KISTLER, William H.">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/kistler-william-h/" title="KISTLER, William H.">KISTLER, William H.</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-30T00:00:00-07:00">March 30, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/o_Hale032821.jpg" href="https://newspress.com/hale-thomas-iii/" title="HALE, Thomas, III">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/hale-thomas-iii/" title="HALE, Thomas, III">HALE, Thomas, III</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T00:00:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/o_Johnson032821.jpg" href="https://newspress.com/johnson-mary-luella-tucker/" title="JOHNSON, Mary Luella (Tucker)">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/johnson-mary-luella-tucker/" title="JOHNSON, Mary Luella (Tucker)">JOHNSON, Mary Luella (Tucker)</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-28T00:00:00-07:00">March 28, 2021</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3231">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/09/c_MICHAEL_WIlliam.jpg" href="https://newspress.com/michael-william-ray/" title="MICHAEL, WILLIAM RAY">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/michael-william-ray/" title="MICHAEL, WILLIAM RAY">MICHAEL, WILLIAM RAY</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2019-03-07T11:14:57-08:00">March 7, 2019</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/08/Obits_noimageavailable-e1596584610295.jpg" href="https://newspress.com/muriel-ghormley-krebs-memorial/" title="Muriel Ghormley Krebs Memorial">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/muriel-ghormley-krebs-memorial/" title="Muriel Ghormley Krebs Memorial">Muriel Ghormley Krebs Memorial</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2014-01-08T12:46:00-08:00">January 8, 2014</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/themes/soledad/images/no-image.jpg" href="https://newspress.com/ervin-g-birzer/" title="Ervin G. Birzer">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/ervin-g-birzer/" title="Ervin G. Birzer">Ervin G. Birzer</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2013-06-23T16:27:27-07:00">June 23, 2013</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/themes/soledad/images/no-image.jpg" href="https://newspress.com/adela-ward/" title="ADELA  WARD">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/adela-ward/" title="ADELA  WARD">ADELA WARD</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2013-06-11T15:16:53-07:00">June 11, 2013</time></p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-3230">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2020/08/Obits_noimageavailable-e1596584610295.jpg" href="https://newspress.com/frank-papa-holguin/" title="FRANK &#8220;PAPA&#8221; HOLGUIN">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/frank-papa-holguin/" title="FRANK &#8220;PAPA&#8221; HOLGUIN">FRANK &#8220;PAPA&#8221; HOLGUIN</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-14T00:00:00-08:00">March 14, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/03/m_Saucedo090721.jpg" href="https://newspress.com/alejandro-alex-saucedo/" title="ALEJANDRO &#8220;ALEX&#8221; SAUCEDO">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/alejandro-alex-saucedo/" title="ALEJANDRO &#8220;ALEX&#8221; SAUCEDO">ALEJANDRO &#8220;ALEX&#8221; SAUCEDO</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-03-07T00:00:00-08:00">March 7, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/02/m_Gathercole022821.jpg" href="https://newspress.com/jon-gathercole-2/" title="JON GATHERCOLE">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/jon-gathercole-2/" title="JON GATHERCOLE">JON GATHERCOLE</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-02-28T00:00:18-08:00">February 28, 2021</time></p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																																<a class="penci-image-holder penci-lazy" data-src="https://newspress.com/wp-content/uploads/2021/02/m_Carmona-In-Memory021821.jpg" href="https://newspress.com/mavis-carmona-rosales/" title="MAVIS CARMONA (ROSALES)">
																									</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://newspress.com/mavis-carmona-rosales/" title="MAVIS CARMONA (ROSALES)">MAVIS CARMONA (ROSALES)</a>
								</h3>
																<p class="penci-mega-date"><time class="entry-date published" datetime="2021-02-18T00:00:10-08:00">February 18, 2021</time></p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22906"><a href="https://newspress.com/place-an-obituary/">Place An Obituary</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8238"><a target="_blank" href="http://174.127.32.54/Top/Search/advancedSearch.jsp">Archives</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-22903"><a href="#">Resources</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22904"><a target="_blank" href="https://newspress.com/employment/">Employment</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22905"><a href="https://newspress.com/photo-reprint-request-form/">Photo Reprints</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22907"><a href="https://newspress.com/advertising/">Place An Ad</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22908"><a href="https://newspress.com/how-to-place-celebration-announcements/">Place A Celebration Announcement</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23293"><a target="_blank" href="http://morenews.newspress.com/kzsb/player.html">KZSB News-Press Radio</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20970"><a href="https://newspress.com/login/">Login</a></li>
<li class="subscribe-menu menu-item menu-item-type-custom menu-item-object-custom menu-item-20971"><a href="https://newspress.com/subscribe">SUBSCRIBE</a></li>
</ul><div id="top-search" class="dfdf">
	<a class="search-click"><i class="penci-faicon fa fa-search" ></i></a>
	<div class="show-search">
		<form role="search" method="get" id="searchform" action="https://newspress.com/">
    <div>
		<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
	 </div>
</form>		<a class="search-click close-search"><i class="penci-faicon fa fa-close" ></i></a>
	</div>
</div>									<div id="top-search" class="shoping-cart-icon"><a class="cart-contents" href="https://newspress.com" title="View your shopping cart"><i class="penci-faicon fa fa-shopping-cart" ></i><span>0</span></a></div>
				
				
			</div>
		</nav><!-- End Navigation -->
			</header>
<!-- end #header --></div>		<div class="penci-header-signup-form">
			<div class="container">
				<aside id="custom_html-9" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!--
<h1 style="font-size:200%;color:red;">
We are having Press Mechanical Issues, so we will not be printing Wednesday's morning paper.  Thank you for being a loyal subscriber and we appreciate your patience.  Subcribers can view the virtual edition of our paper on this website.
</h1>
--></div></aside><aside id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1028104/Homepage_728x90_TOP', [728, 90], 'div-gpt-ad-1601742688507-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<!-- /1028104/Homepage_728x90_TOP -->
<div id='div-gpt-ad-1601742688507-0' style='width: 728px; height: 90px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1601742688507-0'); });
  </script>
</div></div></aside>			</div>
		</div>
	
			<div class="container penci-breadcrumb single-breadcrumb">
			<span><a class="crumb" href="https://newspress.com/">Home</a></span><i class="penci-faicon fa fa-angle-right" ></i>			<span><a class="crumb" href="https://newspress.com/category/local/">Local</a></span><i class="penci-faicon fa fa-angle-right" ></i></i>			<span>United Way offers millions in rent relief</span>
		</div>
			
	<div class="penci-single-pheader container container-single container-single-magazine right-sidebar container-single-fullwidth hentry">
			

				


	<div class="header-standard header-classic single-header penci-title-bellow">
					<div class="penci-standard-cat penci-single-cat"><span class="cat"><a class="penci-cat-name" href="https://newspress.com/category/local/"  rel="category tag">Local</a></span></div>
		
		<h1 class="post-title single-post-title entry-title">United Way offers millions in rent relief</h1>

					<div class="post-box-meta-single">
									<span class="author-post byline"><span class="author vcard">by <a class="author-url url fn n" href="https://newspress.com/author/mhirneisen/">Madison Hirneisen</a></span></span>
													<span><time class="entry-date published" datetime="2021-03-31T05:57:00-07:00">March 31, 2021</time></span>
													<span>0 comment</span>
											</div>
			</div>

		</div>

<div class="container container-single container-single-magazine penci_sidebar right-sidebar penci-enable-lightbox">
	<div id="main" class="penci-main-sticky-sidebar">
		<div class="theiaStickySidebar">
											<article id="post-31880" class="post type-post status-publish">

	
				
	
		<div class="tags-share-box tags-share-box-top center-box tags-share-box-s1">
							<span class="single-comment-o"><i class="penci-faicon fa fa-comment-o" ></i>0 comment</span>
		
					<div class="post-share">
									<span class="post-share-item post-share-plike">
					<span class="count-number-like">0</span><a class="penci-post-like single-like-button" data-post_id="31880" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o" ></i></a>					</span>
				
				<div class="list-posts-share"><a class="post-share-item post-share-facebook" target="_blank" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://newspress.com/united-way-offers-millions-in-rent-relief/"><i class="penci-faicon fa fa-facebook" ></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20United%20Way%20offers%20millions%20in%20rent%20relief%20-%20https://newspress.com/united-way-offers-millions-in-rent-relief/"><i class="penci-faicon fa fa-twitter" ></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-pinterest" data-pin-do="none" rel="nofollow noreferrer noopener" onclick="var e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e);"><i class="penci-faicon fa fa-pinterest" ></i><span class="dt-share">Pinterest</span></a><a class="post-share-item post-share-email" target="_blank" rel="nofollow" href="mailto:?subject=United%20Way%20offers%20millions%20in%20rent%20relief&#038;BODY=https://newspress.com/united-way-offers-millions-in-rent-relief/"><i class="penci-faicon fa fa-envelope" ></i><span class="dt-share">Email</span></a></div>			</div>
			</div>
	<div class="post-entry blockquote-style-2">
		<div class="inner-post-entry entry-content" id="penci-post-entry-inner">
			
<p>The United Way of Santa Barbara County is in the early stages of distributing more than $13 million in rental and utility assistance for residents hit the hardest by COVID-19.&nbsp;</p>



<p>The relief funding comes after a difficult pandemic year for thousands across the county, some of whom are experiencing financial struggles for the first time.&nbsp;</p>



<p>Earlier this year, the Santa Barbara County Board of Supervisors allocated $13 million in funding to the nonprofit’s Emergency Rent Assistance Program to assist residents who experienced significant income loss during the pandemic. Since February, the United Way has helped more than 200 individuals and families and allocated a total of $1.5 million in funding, with plans to allocate the remaining $11.5 million by the end of the year.&nbsp;</p><div class='code-block code-block-1' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'>
<!-- /1028104/InPost_leaderboard1 -->
<div id='div-inpost-leader1' style='width: 728px; height: 90px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-inpost-leader1'); });
  </script>
</div>
<!-- /1028104/inpost_mobile1 -->
<div id='div-gpt-ad-1576899293313-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1576899293313-0'); });
  </script>
</div></div>




<p>“Families who are so desperate right now and facing obstacles are finding respite in this funding,” Melinda Cabrera, the United Way’s director of strategic partnerships, told the News-Press. “They’re able to put food on the table because they know rent and utilities are paid for.”&nbsp;</p>



<p>All county residents at or below 80% of the Area Median Income can qualify for the relief funding, though qualified individuals at or below 50% of the AMI will take priority, according to a news release from the United Way. AMI totals vary depending on the number of individuals residing in a household, and specific totals can be found at unitedwaysb.org/rent.&nbsp;</p>



<p>Upon approval, qualifying households can receive up to $6,000 over three months towards rent and utility expenses. Applicants can re-apply for funding every three months for a maximum of 15 months. The payments are distributed directly to the landlord and/or utility providers on behalf of the household.</p>



<p>Currently the organization has received more than 4,800 applications for relief funding, and officials are creating a more robust system that can process requests more efficiently, Ms. Cabrera said.</p>



<p>Despite a large number of applications, Ms. Cabrera said she still encourages people to apply because there is nearly $12 million in remaining funds that can be claimed.&nbsp;</p>



<p>“It certainly is a large number (of applications), and it did surpass expectations, but it’s just a testament to the overwhelming need right now and how COVID has affected many throughout the county,” Ms. Cabrera said. “It placed families who were already vulnerable in a higher category of risk.”&nbsp;</p>



<p>The funding for this program will remain available until Dec. 30, or until all funds are expended, whichever comes first. At the current rate, Ms. Cabrera said the United Way is hoping to expend 60% of the funds by the end of September.&nbsp;</p>



<p>All community members are welcome to apply on the United Way’s website, Ms. Cabrera said, noting that citizenship status is not a qualifying factor to receive funding.&nbsp;</p>



<p>For more information on the funding and to apply for relief, visit unitedwaysb.org/rent. After applying, individuals will be contacted by a representative from the United Way Family Services Agency who will review their application and request further documentation.&nbsp;</p>



<p>email: mhirneisen@newspress.com</p><div class='code-block code-block-2' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'>
<!-- /1028104/InPost_leaderboard2 -->
<div id='div-inpost-leader2' style='width: 728px; height: 90px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-inpost-leader2'); });
  </script>
</div>
<!-- /1028104/inpost_mobile2 -->
<div id='div-gpt-ad-1576899369282-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1576899369282-0'); });
  </script>
</div></div>

<div id="issuem-leaky-paywall-articles-remaining-nag"></div><!-- AI CONTENT END 3 -->
			
			<div class="penci-single-link-pages">
						</div>
			
					</div>
	</div>

	
		<div class="tags-share-box center-box tags-share-box-s1">
							<span class="single-comment-o"><i class="penci-faicon fa fa-comment-o" ></i>0 comment</span>
		
					<div class="post-share">
									<span class="post-share-item post-share-plike">
					<span class="count-number-like">0</span><a class="penci-post-like single-like-button" data-post_id="31880" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o" ></i></a>					</span>
								<div class="list-posts-share"><a class="post-share-item post-share-facebook" target="_blank" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://newspress.com/united-way-offers-millions-in-rent-relief/"><i class="penci-faicon fa fa-facebook" ></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20United%20Way%20offers%20millions%20in%20rent%20relief%20-%20https://newspress.com/united-way-offers-millions-in-rent-relief/"><i class="penci-faicon fa fa-twitter" ></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-pinterest" data-pin-do="none" rel="nofollow noreferrer noopener" onclick="var e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e);"><i class="penci-faicon fa fa-pinterest" ></i><span class="dt-share">Pinterest</span></a><a class="post-share-item post-share-email" target="_blank" rel="nofollow" href="mailto:?subject=United%20Way%20offers%20millions%20in%20rent%20relief&#038;BODY=https://newspress.com/united-way-offers-millions-in-rent-relief/"><i class="penci-faicon fa fa-envelope" ></i><span class="dt-share">Email</span></a></div>			</div>
			</div>
	
	
			<div class="post-author">
	<div class="author-img">
		<img alt='' src='https://secure.gravatar.com/avatar/4259d64353e25d3648ebcf2284f8f6b2?s=100&#038;d=blank&#038;r=g' srcset='https://secure.gravatar.com/avatar/4259d64353e25d3648ebcf2284f8f6b2?s=200&#038;d=blank&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy'/>	</div>
	<div class="author-content">
		<h5><a href="https://newspress.com/author/mhirneisen/" title="Posts by Madison Hirneisen" rel="author">Madison Hirneisen</a></h5>
		<p>News-Press Staff Writer</p>
																					</div>
</div>	
	
		
		
	
	
			<div class="post-pagination">
				<div class="prev-post">
						<div class="prev-post-inner">
				<div class="prev-post-title">
					<span>previous post</span>
				</div>
				<a href="https://newspress.com/city-council-debates-building-size-limits/">
					<div class="pagi-text">
						<h5 class="prev-title">City Council debates building size limits</h5>
					</div>
				</a>
			</div>
		</div>
	
			<div class="next-post">
						<div class="next-post-inner">
				<div class="prev-post-title next-post-title">
					<span>next post</span>
				</div>
				<a href="https://newspress.com/larsens-to-sell-magic-castle-cabaret/">
					<div class="pagi-text">
						<h5 class="next-title">Larsens to sell Magic Castle Cabaret</h5>
					</div>
				</a>
			</div>
		</div>
	</div>	
		
		
	
	
	
					
		
	
	
	
		
			<div class="post-comments no-comment-yet" id="comments">
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/united-way-offers-millions-in-rent-relief/#respond" style="display:none;">Cancel Reply</a></small></h3><p class="must-log-in">You must be <a href="https://newspress.com/wp-login.php?redirect_to=https%3A%2F%2Fnewspress.com%2Funited-way-offers-millions-in-rent-relief%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	</div> <!-- end comments div -->
		
		
	
</article>					</div>
	</div>
	
<div id="sidebar" class="penci-sidebar-right penci-sidebar-content style-5 pcalign-left penci-sticky-sidebar">
	<div class="theiaStickySidebar">
		<aside id="date-time-2" class="widget widget_date_time"><!-- This file is used to markup the public-facing widget. -->
<div id="date-time" class="date-time" style="color: #ffffff;
  background-color: #000000;
  font-family: Arial, Arial, Helvetica, sans-serif;
  font-size: 20px;">
  <div class="date"></div>
  <div class="time"></div>
</div>
<script type="text/javascript">
  update('date-time-2',
    'none',
    'long');
</script></aside><aside id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- /1028104/Homepage_ATF_300x250 -->
<div id='div-gpt-ad-1573199819719-0' style='width: 300px; height: 250px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1573199819719-0'); });
		setInterval(function() {googletag.pubads().refresh([_Mrec]);}, 20000);
  </script>
</div></div></aside><aside id="categories-2" class="widget widget_categories"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Categories</span></h4><form action="https://newspress.com" method="get"><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="3460">Breaking News</option>
	<option class="level-0" value="3231">Celebration of Life</option>
	<option class="level-0" value="3452">Celebrations</option>
	<option class="level-0" value="3200">Community Superhero</option>
	<option class="level-0" value="2920">Coronavirus Pandemic 2020</option>
	<option class="level-0" value="3450">Death Notices</option>
	<option class="level-0" value="3462">Election</option>
	<option class="level-0" value="50">Featured</option>
	<option class="level-0" value="851">Foresters</option>
	<option class="level-0" value="1610">High School Sports</option>
	<option class="level-0" value="3230">In Memorium</option>
	<option class="level-0" value="24">Life</option>
	<option class="level-0" value="8">Local</option>
	<option class="level-0" value="3448">News Brief</option>
	<option class="level-0" value="3025">Note To Readers</option>
	<option class="level-0" value="13">Obituaries</option>
	<option class="level-0" value="11">Opinions-Letters</option>
	<option class="level-0" value="3449">PETS of the WEEK</option>
	<option class="level-0" value="852">SBCC Sports</option>
	<option class="level-0" value="1655">Scene</option>
	<option class="level-0" value="9">Sports</option>
	<option class="level-0" value="3451">Traffic &amp; Crime Blotter</option>
	<option class="level-0" value="850">UCSB Sports</option>
	<option class="level-0" value="1">Uncategorized</option>
	<option class="level-0" value="10">Voices</option>
	<option class="level-0" value="2921">Westmont Sports</option>
</select>
</form>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</aside><aside id="penci_popular_news_widget-3" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4>				<ul id="penci-popularwg-6873" class="side-newsfeed display-order-numbers">

					
						<li class="penci-feed">
															<span class="order-border-number">
								<span class="number-post">1</span>
							</span>
														<div class="side-item">
																	<div class="side-image">
																															<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://newspress.com/wp-content/uploads/2021/03/lcw-Cannabis-033021-1-1-263x175.jpg" href="https://newspress.com/upset-over-cannabis-odor/" title="Upset over cannabis odor"></a>
										
																			</div>
																<div class="side-item-text">
									<h4 class="side-title-post">
										<a href="https://newspress.com/upset-over-cannabis-odor/" rel="bookmark" title="Upset over cannabis odor">
											Upset over cannabis odor										</a>
									</h4>
																			<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-30T06:00:00-07:00">March 30, 2021</time></span>
																	</div>
							</div>
						</li>

						
						<li class="penci-feed">
															<span class="order-border-number">
								<span class="number-post">2</span>
							</span>
														<div class="side-item">
																	<div class="side-image">
																															<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://newspress.com/wp-content/uploads/2021/03/o_Sims-033121-_2-192x175.jpg" href="https://newspress.com/sims-hannah-elizabeth/" title="SIMS, Hannah Elizabeth"></a>
										
																			</div>
																<div class="side-item-text">
									<h4 class="side-title-post">
										<a href="https://newspress.com/sims-hannah-elizabeth/" rel="bookmark" title="SIMS, Hannah Elizabeth">
											SIMS, Hannah Elizabeth										</a>
									</h4>
																			<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-31T00:00:00-07:00">March 31, 2021</time></span>
																	</div>
							</div>
						</li>

						
						<li class="penci-feed">
															<span class="order-border-number">
								<span class="number-post">3</span>
							</span>
														<div class="side-item">
																	<div class="side-image">
																															<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://newspress.com/wp-content/uploads/2021/03/lfw-MedalWinner-033021-1-263x175.jpg" href="https://newspress.com/heroic-goleta-veteran/" title="Heroic Goleta veteran"></a>
										
																			</div>
																<div class="side-item-text">
									<h4 class="side-title-post">
										<a href="https://newspress.com/heroic-goleta-veteran/" rel="bookmark" title="Heroic Goleta veteran">
											Heroic Goleta veteran										</a>
									</h4>
																			<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-30T05:30:00-07:00">March 30, 2021</time></span>
																	</div>
							</div>
						</li>

						
						<li class="penci-feed">
															<span class="order-border-number">
								<span class="number-post">4</span>
							</span>
														<div class="side-item">
																	<div class="side-image">
																															<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://newspress.com/wp-content/uploads/2019/08/sbnp-letters-to-the-editor-31-263x175.jpg" href="https://newspress.com/chinese-are-laughing-at-us/" title="Chinese are laughing at us"></a>
										
																			</div>
																<div class="side-item-text">
									<h4 class="side-title-post">
										<a href="https://newspress.com/chinese-are-laughing-at-us/" rel="bookmark" title="Chinese are laughing at us">
											Chinese are laughing at us										</a>
									</h4>
																			<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-28T05:35:00-07:00">March 28, 2021</time></span>
																	</div>
							</div>
						</li>

						
						<li class="penci-feed">
															<span class="order-border-number">
								<span class="number-post">5</span>
							</span>
														<div class="side-item">
																	<div class="side-image">
																															<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://newspress.com/wp-content/uploads/2021/03/spw-basketball-0330211-cropped-263x175.jpg" href="https://newspress.com/gauchos-look-to-build-on-the-success-of-ncaa-tournament-run/" title="Gauchos look to build on the success of NCAA Tournament run"></a>
										
																			</div>
																<div class="side-item-text">
									<h4 class="side-title-post">
										<a href="https://newspress.com/gauchos-look-to-build-on-the-success-of-ncaa-tournament-run/" rel="bookmark" title="Gauchos look to build on the success of NCAA Tournament run">
											Gauchos look to build on the success of NCAA Tournament run										</a>
									</h4>
																			<span class="side-item-meta"><time class="entry-date published" datetime="2021-03-30T05:53:00-07:00">March 30, 2021</time></span>
																	</div>
							</div>
						</li>

						
				</ul>

			</aside><aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- /1028104/Homepage_BTF_300x250 -->
<div id='div-gpt-ad-1573203443043-0' style='width: 300px; height: 600px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1573203443043-0'); });
			setInterval(function() {googletag.pubads().refresh([_Mrec]);}, 20000);
  </script>
</div></div></aside>	</div>
</div><!-- END CONTAINER -->
</div>

<div class="clear-footer"></div>


		<div id="widget-area">
			<div class="container">
									<div class="footer-widget-wrapper footer-widget-style-4">
						<aside id="media_image-2" class="widget widget_media_image"><a href="/home"><img width="300" height="104" src="https://newspress.com/wp-content/uploads/2019/04/sbnp-logo-word300-white-300x104.png" class="image wp-image-264  attachment-medium size-medium" alt="Santa Barbara News-Press wordmark white" loading="lazy" style="max-width: 100%; height: auto;" /></a></aside>					</div>
					<div class="footer-widget-wrapper footer-widget-style-4">
						<aside id="nav_menu-4" class="widget widget_nav_menu"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Resources</span></h4><div class="menu-footer-1-container"><ul id="menu-footer-1" class="menu"><li id="menu-item-23296" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23296"><a target="_blank" rel="noopener" href="https://newspress.com/employment/">Employment</a></li>
<li id="menu-item-22658" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22658"><a target="_blank" rel="noopener" href="https://newspress.com/photo-reprint-request-form/">Photo Reprint Form</a></li>
<li id="menu-item-22656" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22656"><a target="_blank" rel="noopener" href="https://newspress.com/place-an-obituary/">Place an Obituary</a></li>
<li id="menu-item-22657" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22657"><a target="_blank" rel="noopener" href="https://newspress.com/how-to-place-celebration-announcements/">Place A Celebration Announcement</a></li>
<li id="menu-item-23298" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23298"><a target="_blank" rel="noopener" href="http://morenews.newspress.com/kzsb/player.html">KZSB News-Press Radio</a></li>
</ul></div></aside>					</div>
					<div class="footer-widget-wrapper footer-widget-style-4">
						<aside id="nav_menu-3" class="widget widget_nav_menu"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Contact Us</span></h4><div class="menu-footer-2-container"><ul id="menu-footer-2" class="menu"><li id="menu-item-259" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-259"><a href="https://newspress.com/contact/">Contact</a></li>
<li id="menu-item-254" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-254"><a href="https://newspress.com/advertising/">Place an Ad</a></li>
<li id="menu-item-8065" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8065"><a target="_blank" rel="noopener" href="http://174.127.32.54/payment/index.html">Pay Your Bill</a></li>
</ul></div></aside>					</div>
					<div class="footer-widget-wrapper footer-widget-style-4 last">
						<aside id="nav_menu-2" class="widget widget_nav_menu"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Your Subscription</span></h4><div class="menu-footer-3-container"><ul id="menu-footer-3" class="menu"><li id="menu-item-20617" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20617"><a href="https://newspress.com/account/">Your Account</a></li>
<li id="menu-item-20618" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20618"><a href="https://newspress.com/subscribe/">Subscribe</a></li>
<li id="menu-item-11267" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11267"><a href="https://newspress.com/login/">Login</a></li>
</ul></div></aside>					</div>
							</div>
		</div>



<footer id="footer-section" class="penci-footer-social-media penci-lazy footer-social-remove-circle" itemscope itemtype="https://schema.org/WPFooter">
	<div class="container">
					<div class="footer-socials-section">
				<ul class="footer-socials">
											<li><a href="https://www.facebook.com/santabarbaranewspress/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook" ></i><span>Facebook</span></a></li>
																<li><a href="https://twitter.com/sbnpnews" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter" ></i><span>Twitter</span></a></li>
																<li><a href="https://instagram.com/sbnpnews" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram" ></i><span>Instagram</span></a></li>
																																														<li><a href="mailto:webmaster@newspress.com"><i class="penci-faicon fa fa-envelope" ></i><span>Email</span></a></li>
																																																																																																																																											</ul>
			</div>
									<div class="footer-logo-copyright footer-not-logo footer-not-gotop">
				
				
									<div id="footer-copyright">
						<p>©2020 - All Rights Reserved. Santa Barbara News-Press / Ampersand Publishing, LLC unless otherwise specified.</p>
					</div>
											</div>
							<div class="penci-go-to-top-floating"><i class="penci-faicon fa fa-angle-up" ></i></div>
			</div>
</footer>

</div><!-- End .wrapper-boxed -->

<div id="fb-root"></div>
	<div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all">
		<div class="penci-gprd-law">
			<p>
				This website uses cookies to improve your experience. Click "Accept" to agree and continue.				<a class="penci-gprd-accept" href="#">Accept</a>				<a class="penci-gprd-more" href="https://newspress.com/terms-of-service/">Read More</a>			</p>
		</div>
			</div>

			<style>
				.single article .entry-content {
					display: none;
				}
			</style>
	<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
	<script type='text/javascript' src='https://newspress.com/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4' id='js-cookie-js'></script>
<script type='text/javascript' id='woocommerce-js-extra'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://newspress.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=5.1.0' id='woocommerce-js'></script>
<script type='text/javascript' id='wc-cart-fragments-js-extra'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_465d92601718c8c262c8074c2e3ddb4a","fragment_name":"wc_fragments_465d92601718c8c262c8074c2e3ddb4a","request_timeout":"5000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://newspress.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=5.1.0' id='wc-cart-fragments-js'></script>
<script type='text/javascript' id='leaky_paywall_basic_shipping-js-extra'>
/* <![CDATA[ */
var leaky_paywall_basic_shipping = {"ajaxurl":"https:\/\/newspress.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://newspress.com/wp-content/plugins/leaky-paywall-basic-shipping/includes/js/script.js?ver=1.6.0' id='leaky_paywall_basic_shipping-js'></script>
<script type='text/javascript' src='https://newspress.com/wp-content/themes/soledad/js/libs-script.min.js?ver=7.2.3' id='penci-libs-js-js'></script>
<script type='text/javascript' id='main-scripts-js-extra'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/newspress.com\/wp-admin\/admin-ajax.php","nonce":"889ea863f6","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript' src='https://newspress.com/wp-content/themes/soledad/js/main.js?ver=7.2.3' id='main-scripts-js'></script>
<script type='text/javascript' id='penci_ajax_like_post-js-extra'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/newspress.com\/wp-admin\/admin-ajax.php","nonce":"889ea863f6","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript' src='https://newspress.com/wp-content/themes/soledad/js/post-like.js?ver=7.2.3' id='penci_ajax_like_post-js'></script>
<script type='text/javascript' id='penci_ajax_more_posts-js-extra'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/newspress.com\/wp-admin\/admin-ajax.php","nonce":"889ea863f6","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript' src='https://newspress.com/wp-content/themes/soledad/js/more-post.js?ver=1.0' id='penci_ajax_more_posts-js'></script>
<script type='text/javascript' src='https://newspress.com/wp-includes/js/comment-reply.min.js?ver=5.6.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://newspress.com/wp-includes/js/wp-embed.min.js?ver=5.6.2' id='wp-embed-js'></script>


</body>
</html>